1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Language problem

Discussion in 'Troubleshooting and Problems' started by ŽivaAkcija, Aug 16, 2015.

  1. ŽivaAkcija

    ŽivaAkcija Well-Known Member

    Changing language does not affect ACP,after set and change language in Croatian, ACP stil shows english setup?

    oie_p7EajakUNZgM.png
     
  2. Amaury

    Amaury Well-Known Member

    As far as I know, that only affects the front end.
     
  3. ŽivaAkcija

    ŽivaAkcija Well-Known Member

    i dont know where is a problem but its looks only my test board got this problems?
     
  4. Martok

    Martok Well-Known Member

  5. ŽivaAkcija

    ŽivaAkcija Well-Known Member

    i know that and i do that but still its a same thing inside ACP shows english setup
     
  6. ŽivaAkcija

    ŽivaAkcija Well-Known Member

    only ACP its a problem on index page got croatian setup, but inside ACP still shows english?
     
  7. CyclingTribe

    CyclingTribe Well-Known Member

    Does XF comes with other languages for ACP or do you have to create / translate them yourself?

    Or perhaps older language packs don't contain the ACP items and they will need adding / translating?
     
  8. ŽivaAkcija

    ŽivaAkcija Well-Known Member

    see here Croatian Language Pack on author board its ok, on my test board failed, on 1.4.10 live board works, only failed on 1.5.RC2
     
  9. Martok

    Martok Well-Known Member

    It wasn't clear that you knew this. Your screenshot shows you changed the language for the front end, it doesn't show a screenshot of the language selector in the footer of the ACP.
     
  10. ŽivaAkcija

    ŽivaAkcija Well-Known Member

    i change language in footer to, like i said so changing language does not affect ACP that is a problems
     
  11. ŽivaAkcija

    ŽivaAkcija Well-Known Member

    setup is ok and must be changed in ACP to but is not?

    Screen Shot 08-16-15 at 10.52 AM.PNG Screen Shot 08-16-15 at 10.53 AM 001.PNG Screen Shot 08-16-15 at 10.53 AM.PNG
     
  12. Martok

    Martok Well-Known Member

    Your screenshots are all for changing the front end, they don't affect the ACP. You have to click on the language in the footer (bottom right corner) of the ACP to change the ACP language.

    It still shows English (US) in the bottom right hand corner of the ACP. When you click on this, are you able to select Croatian? If so when you have clicked on it, is it switching back to English (US)?
     
    ŽivaAkcija likes this.
  13. ŽivaAkcija

    ŽivaAkcija Well-Known Member

    again language in footer shows Hrvatski last attachment
     
  14. ŽivaAkcija

    ŽivaAkcija Well-Known Member

    That solved problems, click on ACP language link, Thanks, but must be changed in ACP to when change language footer link.It is a BUG?
     
  15. Martok

    Martok Well-Known Member

    Probably not. The default language for the front end is English until you change it. It's probably the same for the back end. Remember, all the screenshots you posted are for changing the front end language, they don't affect the language in the ACP.
     
    ŽivaAkcija likes this.
  16. Chris D

    Chris D XenForo Developer Staff Member

    I was just about to move this to bugs and say I would look in more detail...

    But is this the same test forum I logged into recently via a support ticket? If so, then I likely changed the Admin CP language for that account to English ;)

    The language in the front end and back end can now be selected independently. The language in the back end can either be 0 (which would use the front end language) or it can be the ID of any other language (which would override the choice set in the front end). If it's the board I used, I may have set it to English, therefore overriding it to that until you selected something else.
     
  17. ŽivaAkcija

    ŽivaAkcija Well-Known Member

    yes its a same test forum, you can login with same details.
     
  18. Chris D

    Chris D XenForo Developer Staff Member

    I don't need to log in :) It just explains why the language wasn't changing - I set it to English in the Admin CP. That overrides the front end setting.
     
    ŽivaAkcija likes this.
  19. ŽivaAkcija

    ŽivaAkcija Well-Known Member

    yes ok got it now, thanks!!
     

Share This Page