• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Javascript error when moving smileys

#1
I receive an error when trying to move smileys. It didn't happen a few days ago but suddenly started recently.



Add ons I have are:

CTA Table BB Code 1.1.1

sonnb - Profanity Filter 1.0.4

TaigaChat Pro 1.4.3

vBSEO Likes Importer 1.0

[8wayRun.Com] XenAtendo (Events) 1.5.0

[8wayRun.Com] XenPorta (Portal) 1.6.0

Can anyone help?
 
Last edited:

Mike

XenForo developer
Staff member
#3
Roughly how many smilies do you have? There may be some server configuration limits being hit here.
 
#4
Open the browser inspector and check the console tab for the error details.

Am I in the right section? I'm not really sure how to interpret this information or where to go.

Roughly how many smilies do you have? There may be some server configuration limits being hit here.
I went to the export tab to check, it looks like I have 515. Now that you mention it I recently went over 500, that might have something to do with it. Anyway to verify if this is the problem and if so increase this limit?
 

Brogan

XenForo moderator
Staff member
#5
Can you navigate to /admin.php?tools/phpinfo and search for max_input_vars and post what that value is set to?
 
#8
Can you try increasing it 2,000 to see if that changes anything.
Maybe an obvious question but how do I do that? I searched for max_input_vars in php.ini and couldn't find it. So I manually added the line

max_input_vars = 3000
but it didn't update in that admin.php?tools/phpinfo section.
 

Tracy Perry

Well-known member
#9
Maybe an obvious question but how do I do that? I searched for max_input_vars in php.ini and couldn't find it. So I manually added the line

max_input_vars = 3000
but it didn't update in that admin.php?tools/phpinfo section.
Depends on whether you are on a shared hosting or VPS/dedi.
If VPS/Dedi, then you can check your php info page for your Configuration File (php.ini) Path and the Loaded configuration file.
Screen Shot 2015-12-24 at 11.58.25 AM.png

After adding it, you need to restart your php processor - and if using Apache probably Apache.

and this topic from 2014 details the same issue back then
https://xenforo.com/community/threads/1-3-2-smilie-import-problem.75002/#post-771926
 
#13
Try adding - in your .htaccess
max_input_vars = 3000
Seemed to cause my site to stop functioning when I added this in, not sure if I added it in the correct place though. Is there a particular place I'm supposed to add it?
If that doesn't work, try creating a php.ini in your root directory of your web server and put it in there.
There's already a php.ini file in my root directory, I tried adding max_input_vars = 3000 to it but it didn't seem to affect anything.


I contacted my host's support:
10:06:15 AM
Jacob
Thank you for contacting Live Support! My name is Jacob and I will be assisting you today. Please allow me a few minutes to review your initial question and gather any relevant account data.
10:06:20 AM
Jacob
Hello, how are you today?
10:06:34 AM
Jacob
Review the article below to assist you with your request.

wordpress.org/support/topic/increase-max_input_vars-value-and-htaccess
10:06:38 AM
Me
Hi, I'm doing fine
10:07:24 AM
Me
I just put that line in my htaccess?
10:07:41 AM
Me
Not php.ini?
10:09:51 AM
Me
FYI this isn't for wordpress, don't know if it'd be the same on both
10:13:08 AM
Jacob
I do apologize, as this would be Site Customization, this would technically be out of the scope of our support, but how was the site built, and I will look up some useful information for you.
10:14:32 AM
Me
ah, okay. I was using software called "Xenforo", I was receiving error messages with it. Their support told me edit the max_input_vars php setting, but I couldn't find this setting in my php.ini file where I expected it
10:14:43 AM
Me
It's set to 1,000 by default
10:15:53 AM
Jacob
Yes as default I believe this is the standard setting. Please allow me one moment to look up some information, thank you for your patience.
10:15:53 AM
Me
It isn't in the php settings listed as "cannot be changed" support.hostgator.com/articles/cpanel/php-settings-that-cannot-be-changed so I thought there'd be some way to change it
10:18:55 AM
Jacob
Thank you for this information.
10:27:29 AM
Jacob
I do apologize for the wait.
10:27:46 AM
Jacob
I was not able to find any conclusive information to assist you with your request.
10:28:50 AM
Me
So, what happens now? Is there another support representative who might know more about this?
10:28:51 AM
Me
10:35:32 AM
Jacob
I do apologize this would generally be out of the scope of support, so I can not say if someone else will know this, but I can tell you that you should be able to make a php.ini file, and code it with a default php coding and add in this record.
10:35:49 AM
Jacob
Review the article below to assist you with your request.

|support.hostgator.com/articles/articles/specialized-help/technical/what-is-php-ini
10:39:31 AM
Jacob
Just checking to ensure you are still there?
10:39:49 AM
Me
Yup
10:39:53 AM
Me
Reading the linked page
10:42:33 AM
Me
Okay guess that's all then thanks

It doesn't sound like it's prohibited from this conversation but he didn't really seem to know exactly how to edit it either.
 

Tracy Perry

Well-known member
#14
So, you have a php.ini file in your /public_html location (or whatever the root is for your hostgator account).
And in it, you've placed
Code:
max_input_vars = 3000
and it's not working - correct?
 
#15
So, you have a php.ini file in your /public_html location (or whatever the root is for your hostgator account).
And in it, you've placed
Code:
max_input_vars = 3000
and it's not working - correct?
Correct, unless there's some delay or something. I checked my admin.php?tools/phpinfo page and it still looks like it was set to 1,000 and the error when moving smileys was still occurring.
 

Tracy Perry

Well-known member
#16
There's already a php.ini file in my root directory, I tried adding max_input_vars = 3000 to it but it didn't seem to affect anything.
place your current php.ini that you have in a convo to me.. I'll look at it and see if I can figure out why it's not working - it should be as that is the supported HostGator process to do it. You must also have specific code in your .htaccess apparently to allow it.
I direct your attention to http://support.hostgator.com/articles/specialized-help/technical/what-is-php-ini
 

Tracy Perry

Well-known member
#17
Follow HostGators instructions
place php.ini in /home directory with options enabled
modify the root /public_html/.htaccess with the following code
Code:
<IfModule mod_suphp.c>
suPHP_ConfigPath /home/username
<Files php.ini>
order allow,deny
deny from all
</Files>
</IfModule>
(modified of course to reflect the correct username)
And guess what.. it not work. Server gives a 500 error.

How to create a new php.ini file in cPanel:

  1. Login to cPanel.
  2. In the Files section, click on the File Manager icon.
  3. Select Home Directory and click Go.
  4. Click the New File button at the top of the page.
  5. In the field called New File Name, enter php.ini and click Create New File.
  6. Click the file named php.ini.
  7. Select the Edit button at the top of the page and click the Edit button in the pop-up box.
You can now input the contents of your php.ini file and click save. For a complete set of default php.ini files for PHP versions 5.2 through 5.5 click the link below.
Note: Click the link below containing ▷ or ▽ to toggle default php.ini files.
contact us
via phone or live chat.
[paste:font size="5"]Making Changes Global
Now that you have an accessible php.ini file you can use the code provided within this section to make the file global for your entire account. This is done by using the SuPHP handler, which designates what php.ini file to execute.

Note: If this step is not completed, the changes made within the custom php.ini file will not take effect and the file will not be referenced when your site is accessed.
The following code should be placed at the top of your .htaccess file inside the public_html folder.

Be sure to replace "username" with your actual cPanel user name.



<IfModule mod_suphp.c>
suPHP_ConfigPath /home/username
<Files php.ini>
order allow,deny
deny from all
</Files>
</IfModule>
After the above steps have been completed you can review your settings and confirm your configuration path by utilizing the phpinfo function. For more information on how to use this function, please refer to the following article:
Did I mention I don't like HostGator (this was one of the reasons I got off them 3+ years ago).