XF 2.2 Issues with login and password reset caused by Ezoic

Global96

Member
UPDATE: Ezoic is the culprit. GDPR messages are causing the issue somehow. I have contacted them.




Recently I installed a plugin that links XF to WP. I didn't read the instructions properly and ended up wiping a lot of user passwords when syncing XF members to WP. Quickly, I realised that getting users to reset their passwords is the only solution. This has worked for me too, on my alternate accounts. The issue is that some users are reporting that they have needed to reset their passwords multiple times. Each time they need to login again, they need a reset. This shouldn't be caused by the plugin, as I've disabled any further syncing.

Update: Users from GDPR nations cannot login
 
Last edited:

ENF

Well-known member
Can’t help in great detail right this minute, but it would help to know which WP <-> XF package you used.

Be sure to completely remove the plug-in and its files for the time being for troubleshooting.

Also be sure that the site is properly configured for non-www vs www URLs - not sure if this would have changed, but it’s a common issue for getting logged out when going back and forth between the two.
 

hstammlerj

Active member
I've been able to replicate the issue with a VPN. When I try to login (through a VPN), it simply refreshes but keeps me logged out.
So how do the cookies / localstorage look like during the process?
Did you test in a browser cache-free environment?
The only thing can think of is hte .htaccess file. It appears to have changed after the plugin was installed.
Why not change it back? What is the change?

Are you able to restore a "before add-on installation" state in a test environment?

btw: It's probably that bridge? -> https://xenforo.com/community/threads/xftowp-integrate-xenforo-to-wordpress-paid.188385/post-1565508
 

Global96

Member
I think I found the culprit. It's Ezoic. I integrated Ezoic about a week ago. It appears that the login issue is caused by the GDPR message... I tested different locations via VPN and it checks out. The plugin just exacerbated the issue by removing all passwords (my fault for not reading the instructions properly).
 
Read this maybe it can help
I was aware of that thread and the first of the 2 potential fixes had been incorporated from the get go. I have now gone with the 2nd potential fix and will be awaiting feedback from our users. Thanks.
 
Update: I had turned off GDPR on ezoic and installed the 2nd fix from the link above. All worked fine. I then went and enabled GDPR on ezoic and it broke again requiring certain users to have to change passwords before logging in again.
 
Top