XF 2.2 Issues with email

btmgreg

Active member
I've recently upgraded to the latest and greatest version of XF. Not sure what has changed, but I'm getting the following errors in regards to emails.

(I haven't changed any of the settings)

Code:
++ Starting Swift_SmtpTransport
<< 220-server.behind-the-mask.net ESMTP Exim 4.93 #2 Wed, 23 Dec 2020 16:42:38 +0000
220-We do not authorize the use of this system to transport unsolicited,
220 and/or bulk e-mail.

>> EHLO www.behind-the-mask.net

<< 250-server.behind-the-mask.net Hello www.behind-the-mask.net [173.82.245.185]
250-SIZE 52428800
250-8BITMIME
250-PIPELINING
250-AUTH PLAIN LOGIN
250-STARTTLS
250 HELP

>> STARTTLS

<< 220 TLS go ahead

and

Code:
Server error log
ErrorException: Email to greg@behind-the-mask.net failed: [E_WARNING] stream_socket_enable_crypto(): Peer certificate CN=`173-82-245-185.cprapid.com' did not match expected CN=`email-smtp.us-east-1.amazonaws.com' src/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/StreamBuffer.php:94
Generated by: Unknown account Dec 23, 2020 at 4:02 PM
Stack trace
#0 [internal function]: XF::handlePhpError(2, '[E_WARNING] str...', '/home/behindthe...', 94, Array)
#1 src/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/StreamBuffer.php(94): stream_socket_enable_crypto(Resource id #198, true, 57)
#2 src/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/EsmtpTransport.php(348): Swift_Transport_StreamBuffer->startTLS()
#3 src/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php(148): Swift_Transport_EsmtpTransport->doHeloCommand()
#4 src/XF/Mail/Mailer.php(286): Swift_Transport_AbstractSmtpTransport->start()
#5 src/XF/Mail/Queue.php(138): XF\Mail\Mailer->send(Object(Swift_Message), Object(Swift_SmtpTransport), Array)
#6 src/XF/Job/MailQueue.php(12): XF\Mail\Queue->run(8)
#7 src/XF/Job/Manager.php(258): XF\Job\MailQueue->run(8)
#8 src/XF/Job/Manager.php(200): XF\Job\Manager->runJobInternal(Array, 8)
#9 src/XF/Job/Manager.php(84): XF\Job\Manager->runJobEntry(Array, 8)
#10 job.php(43): XF\Job\Manager->runQueue(false, 8)
#11 {main}
Request state
array(4) {
  ["url"] => string(19) "/discussion/job.php"
  ["referrer"] => string(72) "https://www.behind-the-mask.net/discussion/admin.php?logs/server-errors/"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}

No idea what to do. I'm unable to send any test emails.
 
Top