• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Is XFES too literal or do resources work differently to forum threads / posts?

CTXMedia

Formerly CyclingTribe
#1
I tried searching resources for tenants directory a few moments ago. I remembered it had XenKing in the name so put that in the search field; the result was a single thread:

Usergroup Permissions for Xenking Directory Addon 1.0.1

... but, strangely, not the actual add-on thread I was looking for. So I tried again, but this time used directory as the search word and there is was, a few places down the list:

[SurreyForum] XenKingDir: Link / Business Directory (Directory) 1.2.0.8

... so why didn't XFES pick this out when I searched for XenKing? I realise it has 'Dir' tacked onto it, but shouldn't the search algo at least pick it up as a partial match?
 

Mike

XenForo developer
Staff member
#2
... so why didn't XFES pick this out when I searched for XenKing? I realise it has 'Dir' tacked onto it, but shouldn't the search algo at least pick it up as a partial match?
No, in general a partial match would match all sorts of stuff that it shouldn't. If you want a partial match (beyond stemming), you need to add a "*".

FWIW, I don't even see the thread you wanted on Google for "xenking".
 

CTXMedia

Formerly CyclingTribe
#3
Okay, thanks Mike; I'll have to remember to use the wildcard more often. (y)

I've possibly become a little too dependent on stemming (I have it enabled on all my own sites) and forget that it only applies to dictionary words. ;)