1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed IP Info Overlay missing IP for Guests

Discussion in 'Resolved Bug Reports' started by Liam W, Jan 28, 2014.

  1. Liam W

    Liam W Well-Known Member

    Screenshot from 2014-01-28 21:05:46.png
    The IP isn't displayed in the overlay...

    This happens for all IP's. Listeners disabled.

    Liam
     
    jmurrayhead likes this.
  2. Liam W

    Liam W Well-Known Member

    Hmmm, it works fine on my localhost dev install (new install)...

    Liam

    UPDATE: This is probably wrong now. It looks like it only happens for guests, and there's no guests on my dev install so I checked myself, a registered user, for which it works.
     
    Last edited: Jan 28, 2014
  3. Liam W

    Liam W Well-Known Member

    Another update, it only appears to happen for guests...?

    The content IP is filled in on my account.

    Liam
     
  4. AWS

    AWS Well-Known Member

    I can confirm this. No IP info for guests.
     
    jmurrayhead and Liam W like this.
  5. Andy.N

    Andy.N Well-Known Member

    It does not log IP for guests and robots.
     
  6. Liam W

    Liam W Well-Known Member

    Robots are technically guests...

    But, yes.
     
  7. Adam Howard

    Adam Howard Well-Known Member

    Can confirm this issue
     
  8. masterchief

    masterchief Well-Known Member

    Additionally, I am getting these irregularities
    • Current visitors, when clicking on the IP for my login, everything works as expected
    • I am also listed as guest with same IP, but I get following error when clicking on the IP:
    Code:
    ErrorException: hex2bin(): Hexadecimal input string must have an even length - library/XenForo/Helper/Ip.php:163
    Generated By: William Johnson, A moment ago
    
    Stack Trace
    #0 [internal function]: XenForo_Application::handlePhpError(2, 'hex2bin(): Hexa...', '/home4/xxxxxxxx...', 163, Array)
    #1 /home4/newsecon/public_html/library/XenForo/Helper/Ip.php(163): hex2bin('2')
    #2 /home4/newsecon/public_html/library/XenForo/ControllerPublic/Online.php(117): XenForo_Helper_Ip::convertHexToBin('2')
    #3 /home4/newsecon/public_html/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_Online->actionGuestIp()
    #4 /home4/newsecon/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #5 /home4/newsecon/public_html/index.php(13): XenForo_FrontController->run()
    #6 {main}
    
    Request State
    array(3) {
    ["url"] => string(186) "http://xxxxxxxx.com/online/guest-ip?ip=2%0D%2F%15&&_xfRequestUri=%2Fonline%2F&_xfNoRedirect=1&_xfToken=1%2C1390951198%2Ca495637bac5e961e5f26902725fe262f2b5b03ee&_xfResponseType=json"
    ["_GET"] => array(5) {
    ["ip"] => string(4) "2
    /"
    ["_xfRequestUri"] => string(8) "/online/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfToken"] => string(53) "1,1390951198,a495637bac5e961e5f26902725fe262f2b5b03ee"
    ["_xfResponseType"] => string(4) "json"
    }
    ["_POST"] => array(0) {
    }
    }
    
    
     
  9. Mike

    Mike XenForo Developer Staff Member

    Fixed, thanks.
     
    Virosss, Liam W and Adam Howard like this.

Share This Page