Fixed InvalidArgumentException


Well-known member
Affected version
2.1.0 Preview
Today I installed XenForo v2.1.0 Beta 2 and Enhanced search v2.1.0-Preview.

When I try to access Enhanced search in the Admin area I get this:

I uninstalled the XFES add-on then installed again. Now I can get to this page:


However when I click the Test settings button I get the same error as shown in post #1.
Last edited:
The dbname may contain characters that aren't supported by elasticsearch as an index name since by default it uses your database name. Try setting an index name using only alphanumeric characters and underscores.
This appears to be specific to connecting to Elasticsearch with a username and password. This is not commonly needed, as out of the box, Elasticsearch doesn't use this (some derivatives do though). So the workaround for now would be to not enter that.

I have fixed this for the next XFES preview/beta release.
Top Bottom