• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Installion Help (chmod issue)

#1
Hello all,

I am installing my XenForo onto a new website and I have stumbled across an issue I have no idea how to resolve. When I type www.webaddress.com/install it comes up with a series of errors...
  • The directory G:\host\webaddress.com\home/data must be writable. Please change the permissions on this directory to be world writable (chmod 0777). If the directory does not exist, please create it.
  • The directory G:\host\webaddress.com\home/internal_data must be writable. Please change the permissions on this directory to be world writable (chmod 0777). If the directory does not exist, please create it.
Now, I have attempted to change my chmod to 0777 in my FTP client (I am using Filezilla) however it comes up with the message:
Status: Set permissions of '/home/data' to '0777'
Command: SITE CHMOD 0777 data
Response: 500 'SITE': command not understood
I have tried over and over again however I cannot find a way to install XenForo as I cannot get past this error.

Any help would be greatly appreciated, thanks.
 

Brogan

XenForo moderator
Staff member
#2
That sounds like a host issue in that they have limited the ability to chmod via FTP.

Try via cPanel if you have it installed.

You may also want to ask your host why they have disabled it; it may be an oversight (unlikely), or it could be a deliberate restriction.
 
#3
Ok, thanks. I will contact them.

Just out of curiosity, if I contact my host do they often give out the ability to adjust chmod? Or would I struggle to get access? I am not 100% sure what it does, I have just been told to do it. Haha.
 

Brogan

XenForo moderator
Staff member
#4
It relates to changing the directory (and file) permissions.

It's rare for it to be disabled like that but I have seen it a few times.

You can likely do it via cPanel otherwise your host can do it for you.
 

Brogan

XenForo moderator
Staff member
#6
I assumed you already had cPanel installed.
I suspect you don't have shell access, but if you do, you can also run these commands to set the permissions:
Code:
chmod -R 777 data
chmod -R 777 internal_data