1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Installing new xenforo with php 5.3, and then later upgrading 5.4? will there be errors

Discussion in 'Installation, Upgrade, and Import Support' started by jilly, Sep 5, 2015.

  1. jilly

    jilly Member

    I currently have a server with a VB 3 X on it, running php 5.3.26 - I am installing a new xenforo instead of updating, and plan to eventually turn the old vb into a read only archive, and transition users slowly to the new xenforo board. (This is because I have so many customizations and mods installed on my old vb board I don't think I can transfer everything easily to the new board. Would rather leave the old one as is for now, and slowly transition ppl to a clean install of xenforo)

    if I install xenforo now, and then upgrade to php 4 later, will it cause problems? At the moment, I don't want to mess with my existing board -
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Upgrading server software won't affect your XenForo installation.
    XF is compatible with both PHP 5.3 and 5.4.
    jilly likes this.
  3. 0ptima

    0ptima Well-Known Member

    If you are on an older version of VB (< 3.8.8) , a PHP upgrade will most probably break VB and not Xenforo
    jilly likes this.
  4. 0ptima

    0ptima Well-Known Member

  5. ForumCube

    ForumCube Active Member

    @jilly, we were in very similar situation with one of our recent project and we ended up running 2 php versions for supporting old vBulletin forum. As Brogan already suggested XF not got any issue with both php versions.

    If your board is active, its highly recommended to test everything on staging environment to check the compatibility - as its not always the core vB which creates trouble but sometimes customization/plugins can really put you in bad position.
  6. Alex - A2Hosting

    Alex - A2Hosting Active Member

    It is best to run everything in a test install just to be safe. That being said, you should be safe to upgrade.

    Also, some hosting providers allow you to run different PHP versions on each sub domain so if you're using that, defiantly check that out.
  7. Wesker

    Wesker Active Member

    Just need to confirm here. What is your recommended PHP Version for 1.5?
  8. Brogan

    Brogan XenForo Moderator Staff Member

    XF 1.5 works with the latest release of PHP - go with 7 if you can.
  9. Wesker

    Wesker Active Member

    I assume 5.3.2-5.3.4 would not work?
  10. Brogan

    Brogan XenForo Moderator Staff Member

    Yes, it works but we are recommending a minimum version of 5.4, for XF2 compatibility.

Share This Page