• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 2.0 Installing Addons

Haydric

Active member
#1
So I was attempting to install an addon from themehouse seeing that I'm helping with beta testing, but every single time I attempted to install any of the addons it gives me an error saying that it doesn't have permission.

Can anyone help with this?
 

Chris D

XenForo developer
Staff member
#2
Bear in mind XF2 is not yet officially supported and even so, we do not provide support with third party add-ons, so generally the support for installation issues would have to come from the authors.

Though, generally speaking, this would likely be file system permission/ownership issues. As you will have installed XF2 using the CLI, the files created during installation will be owned by whatever user you ran the command as, which is likely different and more privileged than the web server user.

There's some general advice here:
https://xf2demo.xenforo.com/dev-docs/#a-note-on-file-permissions
 

Haydric

Active member
#3
Bear in mind XF2 is not yet officially supported and even so, we do not provide support with third party add-ons, so generally the support for installation issues would have to come from the authors.

Though, generally speaking, this would likely be file system permission/ownership issues. As you will have installed XF2 using the CLI, the files created during installation will be owned by whatever user you ran the command as, which is likely different and more privileged than the web server user.

There's some general advice here:
https://xf2demo.xenforo.com/dev-docs/#a-note-on-file-permissions
Thank you Chris, this really helped me :)