1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Installing a addon

Discussion in 'Troubleshooting and Problems' started by onthefly, May 14, 2012.

  1. onthefly

    onthefly Active Member

    Hi there, I am having problems installing addon's. I never used to have any issues, it was lightning fast when installing now it takes 30 minutes plus having to restart it several times during the process. Anyone have any ideas as to why this happens?
  2. Chris D

    Chris D XenForo Developer Staff Member

    After an add on is installed, a cache refresh is forced. This is a resource intensive process which can increase over time with the number of add-ons and templates you might have.

    That being said, 30 minutes sounds excessive.

    Is there anything logged in the Server Error log on your Admin CP after it fails?

    Do you have access to your server's Apache logs or similar?

    Finally is this on Shared Hosting or a VPS?
    ragtek likes this.
  3. ragtek

    ragtek Guest

    anything in apache or xf error log?
  4. onthefly

    onthefly Active Member

    here is a screen print

  5. Chris D

    Chris D XenForo Developer Staff Member

    I'll be honest, I don't know what any of those mean, but I'm pretty sure 100% of them shouldn't be there in a working configuration.

    One of the tables it complains about is "book_description".

    Do you know what add on this might refer to? Have you got an add on installed to do with books?

    Do things change if this were to be disabled?
  6. onthefly

    onthefly Active Member

    ya, that one has something to do with the Book review addon but happened only when adding a book, not the problem. This has bee happening well before this addon was installed, cheers thanks.
  7. Chris D

    Chris D XenForo Developer Staff Member

    Ok so it's these others:

    Lost connection to MySQL at 'reading authorization packet' errors that might need looking at.

    If you click on one of these what's the output?
  8. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That error is caused by one of these MySQL settings being exceeded:


    Your host or server person needs to increase these settings in MySQL. There is more info here:


    That is a problem with the collations in your database. Read this thread starting from this post:


    I'm not sure what table it's from since the named column (book_description) is not in the default software. It must be a table for an addon. Check the collations.

Share This Page