• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Installation server error

#1
Step 2 of the installation process is giving me the following error:
Mysqli prepare error: CREATE command denied to user 'XXX'@'localhost' for table 'xf_addon'
  1. Zend_Db_Statement_Mysqli->_prepare() in /hsphere/local/home/XXX/xenforo.XXX.net/xf/library/Zend/Db/Statement.phpat line 115
  2. Zend_Db_Statement->__construct() in /hsphere/local/home/XXX/xenforo.XXX.net/xf/library/Zend/Db/Adapter/Mysqli.phpat line 381
  3. Zend_Db_Adapter_Mysqli->prepare() in/hsphere/local/home/XXX/xenforo.XXX.net/xf/library/Zend/Db/Adapter/Abstract.php at line 478
  4. Zend_Db_Adapter_Abstract->query() in/hsphere/local/home/XXX/xenforo.XXX.net/xf/library/XenForo/Install/Model/Install.php at line 174
  5. XenForo_Install_Model_Install->createApplicationTables() in/hsphere/local/home/XXX/xenforo.XXX.net/xf/library/XenForo/Install/Controller/Install.php at line 196
  6. XenForo_Install_Controller_Install->actionStep2() in/hsphere/local/home/XXX/xenforo.XXX.net/xf/library/XenForo/FrontController.php at line 310
  7. XenForo_FrontController->dispatch() in/hsphere/local/home/XXX/xenforo.XXX.net/xf/library/XenForo/FrontController.php at line 132
  8. XenForo_FrontController->run() in /hsphere/local/home/XXX/xenforo.XXX.net/xf/install/index.php at line 17
I have the database name and username/password entered correctly.
 

Brogan

XenForo moderator
Staff member
#2
This is the first table so it indicates that the DB user doesn't have the correct permissions.

Check that the DB user has all privileges, including create.
 
#5
Yeah, I wasn't seeing that. I told it to read and write but there was another privilege page with a list of things and most were not ticked.