XF 1.5 Installation problem

FedericoS

Active member
Hello :)
I'm trying to install xenForo 1.5 on my test server, but I receive this error going to my url:
Fatal error
: Uncaught ErrorException: array_key_exists(): Using array_key_exists() on objects is deprecated. Use isset() or property_exists() instead in /var/www/html/library/Zend/Registry.php:206 Stack trace: #0 /var/www/html/library/Zend/Registry.php(206): XenForo_Application::handlePhpError() #1 /var/www/html/library/Zend/Registry.php(183): Zend_Registry->offsetExists() #2 /var/www/html/library/XenForo/Helper/File.php(284): Zend_Registry::isRegistered() #3 /var/www/html/library/XenForo/Error.php(78): XenForo_Helper_File::getInternalDataPath() #4 /var/www/html/library/XenForo/Application.php(381): XenForo_Error::unexpectedException() #5 [internal function]: XenForo_Application::handleException() #6 {main} thrown in /var/www/html/library/Zend/Registry.php on line 206


How can I solve that? Thanks :)
 

FedericoS

Active member
Hello guys, I've tried to install it on my XAMPP local server with PHP 7.3.2, but I need to install it on my test server and it not works (Also with the same PHP version)
 

FedericoS

Active member
The 1.5.21 version not compatible with PHP 7.3.2 is compatible just with <= 5.6 as I said above,

My XAMPP server is running PHP 7.3
IMAGE 2020-03-28 17:41:57.jpg

but it does not work on my remote server because of this error:
Fatal error: Uncaught ErrorException: array_key_exists(): Using array_key_exists() on objects is deprecated. Use isset() or property_exists() instead in /var/www/html/library/Zend/Registry.php:206 Stack trace: #0 /var/www/html/library/Zend/Registry.php(206): XenForo_Application::handlePhpError() #1 /var/www/html/library/Zend/Registry.php(183): Zend_Registry->offsetExists() #2 /var/www/html/library/XenForo/Helper/File.php(284): Zend_Registry::isRegistered() #3 /var/www/html/library/XenForo/Error.php(78): XenForo_Helper_File::getInternalDataPath() #4 /var/www/html/library/XenForo/Application.php(381): XenForo_Error::unexpectedException() #5 [internal function]: XenForo_Application::handleException() #6 {main} thrown in /var/www/html/library/Zend/Registry.php on line 206

I also tried to downgrade my PHP version from 7.4.4 to 7.3.2 (same as the local server).
 
Top