XF 1.5 Installation Error - "Mysqli prepare error: Table 'xenforo.xf_data_registry' doesn't exist"

Luminxsity

Member
Hello there, so I was trying to setup my Xenforo and once I had done all the steps like uploading all the files to my ftp & going to the install page, multiple errors had occurred when I got to the step to "Create an Administrator". Seemingly, I had solved all the other ones but this one I do not understand nor do I know how to fix it. Please help!!

Code:
Server Error

Mysqli prepare error: Table 'xenforo.xf_data_registry' doesn't exist

Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 825
Zend_Db_Adapter_Abstract->fetchOne() in XenForo/Model/DataRegistry.php at line 64
XenForo_Model_DataRegistry->_getFromDb() in XenForo/Model/DataRegistry.php at line 34
XenForo_Model_DataRegistry->get() in XenForo/Application.php at line 775
XenForo_Application->loadOptions() in XenForo/Application.php at line 973
XenForo_Application->lazyLoad() in XenForo/Application.php at line 1004
XenForo_Application::get() in XenForo/DataWriter/User.php at line 268
XenForo_DataWriter_User->_getDefaultOptions() in XenForo/DataWriter.php at line 277
XenForo_DataWriter->__construct() in XenForo/DataWriter.php at line 2058
XenForo_DataWriter::create() in XenForo/Install/Model/Install.php at line 304
XenForo_Install_Model_Install->insertAdministrator() in XenForo/Install/Controller/Install.php at line 273
XenForo_Install_Controller_Install->actionStep3b() in XenForo/FrontController.php at line 351
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
XenForo_FrontController->run() in /var/www/html/install/index.php at line 18
 

Brogan

XenForo moderator
Staff member
multiple errors had occurred when I got to the step to "Create an Administrator"
What sort of errors?

Installation errors are very rare and in all cases they are either due to a problem when uploading the files, or the server.

I would recommend downloading a new copy of the files and uploading them again (use anything other than Filezilla) and then do a clean installation.
 

Luminxsity

Member
What sort of errors?

Installation errors are very rare and in all cases they are either due to a problem when uploading the files, or the server.

I would recommend downloading a new copy of the files and uploading them again (use anything other than Filezilla) and then do a clean installation.
I had just uploaded all the new files using a different ftp client, entirely new and I was still presented with the same error that I had shown at the beginning. ;-;
 

Mike

XenForo developer
Staff member
Can you try restarting the installation? If it happens again, that would seem to be implying that something is manipulating the database outside of XenForo, as you would get that error on an earlier step if those tables were never actually created.
 

Luminxsity

Member
Thank you guys for the help, I found out the issue. I had one of my friends help me and he had said it was something wrong with MySQL & php saying it didn't want to install or something like that.

However I appreciate the help you have given me! Thank you
 
Top