Install and upgrades post support period

FidoMike

New member
Hi all,
I'm asking this question having just hit this issue on a competitor's software, and wanted to see what the situation would be with XenForo.

If I buy a license, and say i get (version numbers just an example) XF 2.1, I use and run it fine. Then, lets say XF 3.0 is released 6 months later, so within my initial 12 months support. I download XF3.0, but for whatever reason I don't use it. Time passes, and lets say I haven't renewed, so we are at 1 year and a bit past original purchase, out of support. Can I use the XF 3.0 I downloaded during my supported time, and upgrade from my 2.1 to that 3.0, without having a renewed license? To be clear I'm saying the 3.0 released at that time, not anything released post renewal. And again, version numbers are made up examples, I know there is no 3.0 (yet).

What was the situation with XF1.5 to XF2.0?

I guess what I'm asking is, do you need an actual active support/license to run the upgrader / installer for XF at the time its run?

Also, if I buy now, do I get access to XF1.5 and the current version? As it looks like I might need XF1.5 to import IPB3.x

Many thanks for all and any help.
 
Solution
You can download and use any version from XF1.0 to the latest version which is released while your license has active support and downloads.
If you purchase a license now you will be able to download XF2.2 when it becomes available and upgrade to...

Brogan

XenForo moderator
Staff member
You can download and use any version from XF1.0 to the latest version which is released while your license has active support and downloads.
If you purchase a license now you will be able to download XF2.2 when it becomes available and upgrade to any subsequent releases made by 2 July 2021.

An active license is not required to run any upgrades, etc.

There is an IPB importer available for XF2, so you don't need to install XF1, import into that, then upgrade.
 
Solution

FidoMike

New member
Many thanks for the quick reply, and I greatly appreciate not needing an active license to upgrade.

Can XF2 import directly from IPB 3.4.7? I thought it can only import from 4.x. I have the IPB gallery I'd need to import into XFMG as well.

Thanks again.
 
Top