• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Implemented In Open Bug Reports trying to search for all bugs marked confirmed

HydraulicJack

Well-known member
#1
using the Search Threads and Posts tab, I was just trying to search Open Bug reports to get a list of all of the threads with prefixes as Confirmed but got an error since I didn't specify Keywords, Posted by member, or Newer than.

Seems to me that if I specify which subforum (Open Bugs...) and the prefix, I should get the list.

Thot I'd ask. I'll be happy to post a bug, a tweak needed, or function / feature request if appropriate.
Please advise. Thanks!
HJ
 
R

ragtek

Guest
#3
I agree and i think there's already a suggestion thread to remove the "keyword or member" as required fields.

I'd like to search for all threads newer then xxx or like your example => all threads within forum xy with prefix foo.
 
R

ragtek

Guest
#6
as cuvegotti said.

What if you have:

Prefixgroup: Products
Prefixes: Bug, Fixed, Suggestion, Included

Forum: Product1
Forum: Product2
And both have Products Prefix group...

ATM it's AFAIK not possible, to get ALL threads with prefix groups.
 

Brogan

XenForo moderator
Staff member
#7
No, but the original post specifically asked about a single prefix in a single forum.

Clicking the prefix will do that.
 

HydraulicJack

Well-known member
#8
Why not just click on the prefix within the forum?
Makes sense of course and thanks, but by the same token, why EXCLUDE that option from the "advanced" form?
And to me it wasn't intuitively obvious to click on the prefix of any prefixed post (still isn't) to get a list of all of them.
I'm one of your crash test dummies! :D
What I'm understanding you to say is that I can click on any prefix in any post to get a list of all posts with that prefix.
Is my understanding of that correct?
I will check it now of course.
Thanks again Brogan.
 

HydraulicJack

Well-known member
#9
I agree and i think there's already a suggestion thread to remove the "keyword or member" as required fields.

I'd like to search for all threads newer then xxx or like your example => all threads within forum xy with prefix foo.
Exactly!
Also thanks for the heads up about the suggestion thread, ragtek. I couldn't find it easily when I search, so that's why I just started a thread rather than posting it as a bug.
If you happen to know the link to that thread it would be good for one of us to post it here, to point others to it. ;)
 

HydraulicJack

Well-known member
#11
Click on any prefix of any thread within a forum to get a filtered list of all threads with that prefix in that forum.
How is that obvious to a new user (such as I)? Esp when there is no option shown for this in the "advanced" form.
I naturally tend to use the advanced form, but the option is not there. That's my issue.
Nice of course to know that there's another way to get the data, but I think that option still belongs in the Advanced form.
[/end rant]
 

HydraulicJack

Well-known member
#13
Undo: [/end rant]

Yes by golly, clicking on the prefix DOES return a list of all posts with that prefix. Nice!

But... there is no clue, even at mouseover on such a prefix, that that is possible.
You just gotta know.
imho that is just not up to XenForo's otherwise high ease of use standards.

Hence my gripe about the feature's being incomplete as yet.
Not really a bug perhaps in a technical sense but not intuitively obvious...
 

HydraulicJack

Well-known member
#14
I think you misunderstand.

It's only available in the thread list view: http://xenforo.com/community/forums/bugs/

Hover over the Confirmed prefix and click.
Ok, good to know.
How is a naive user supposed to know that it's only available in such and such view?
Do they have to read a manual, or what?
Again imho that doesn't meet the typical highly intuitive usability standard that XF has spoiled us into expecting. :)

It's a GREAT feature / function. Just unfinished imho on the intuitive usability standard.

Retest: [/end rant]
 

Brogan

XenForo moderator
Staff member
#15
XenForo is full of clickable links on the member card, avatars, in posts, threads, etc.

The browser icon changing on mouseover and/or hover effect is usually a good sign that something can be clicked.
 

HydraulicJack

Well-known member
#16
XenForo is full of clickable links on the member card, avatars, in posts, threads, etc.

The browser icon changing on mouseover and/or hover effect is usually a good sign that something can be clicked.
And how is one supposed to know that that is what the icon changing means? It needs a popup TEACHING this to naive users f'gawdsake, in my humble opinion.

BTW, I have gone ahead and posted a reference to the issue in this thread over at the Search improvements and UI tweaks in XenForo 1.1 thread, so we can end it here.

I feel like it's now been duly reported and I'm ready to move on to other issues.

Retest [/end rant]
 

HydraulicJack

Well-known member
#17
XenForo is full of clickable links on the member card, avatars, in posts, threads, etc.

The browser icon changing on mouseover and/or hover effect is usually a good sign that something can be clicked.
Same question though as in #14.

How is a naive user supposed to know this? How do they LEARN it?

Like I just posted, I've made a comment about this in the Search Improvements thread so it'll be dealt with or ignored as TPTB see fit.

Retest: [/end rant]