1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Improve forum home load time

Discussion in 'XenForo Questions and Support' started by jauburn, May 12, 2014.

  1. jauburn

    jauburn Well-Known Member

    My forum home is loading at ~ 3 seconds, which is too slow, even on an SSD-based VPS.

    I notice that xenforo's home page loads much faster.

    Two questions:

    What is xenforo's secret?

    What might I do to improve forum home load times?

    Thanks.
     
  2. Tracy Perry

    Tracy Perry Well-Known Member

    # of add-ons in use
    bandwidth latency
    # of images display on main page
    # of ads displayed on main page
    Social intergration plugin latency

    These ALL have a bearing on it.
     
    jauburn likes this.
  3. MattW

    MattW Well-Known Member

    It's taking 1.3 seconds just to get the initial response from the db queries before it even starts to load the js / images / css etc

    upload_2014-5-12_22-15-20.png

    I'd suggest you start by taking a look at the configurations of the webserver and database, and try and implement caching where possible.
     
    jauburn likes this.
  4. Tracy Perry

    Tracy Perry Well-Known Member

    @jauburn - another thing is give SERIOUS consideration to going to nginx/OpenLiteSpeed/LiteSpeed instead of Apache.
    Dump PHP 5.3.27 and upgrade to the 5.5 series also.
     
  5. jauburn

    jauburn Well-Known Member

    I can't dump 5.3.x at the moment because I have one site that won't work on 5.4.x or higher.

    I'll ask the host about nginx/OpenLiteSpeed, etc.

    Is that what they use here?
     
  6. Tracy Perry

    Tracy Perry Well-Known Member

    They use Apache here... but I'm pretty sure they got a LOT more horsepower behind it than what you have.
    Screen Shot 2014-05-12 at 5.35.05 PM.png
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    The server used for xenforo.com is very modest.

    It's just been tweaked by someone who knows what he's doing ;)

    My server has just 4GB: http://cliptheapex.com/

    upload_2014-5-12_23-42-6.png

    But it has been tweaked by the same guy ;)
     
    Amaury likes this.
  8. Tracy Perry

    Tracy Perry Well-Known Member

    Yes, but if I'm not mistaken he's on a VPS with ServInt.... and XenForo is running (I'm pretty sure) on dedicated iron from SoftLayer?
     
  9. nodle

    nodle Well-Known Member

    I have no idea what I'm doing with tweaks and everything, and mine loads pretty fast. Fluxoid
     
  10. jauburn

    jauburn Well-Known Member

    FYI, I figured out that a low TTL value (set to 0 in some cases) in some of the sidebar blocks--part of the bd widget framework--was causing much of the home page slowness.
     

Share This Page