1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Impossible to get WebDAV work in Ubuntu 13.04

Discussion in 'Troubleshooting and Problems' started by account8226, Jun 24, 2013.

  1. account8226

    account8226 Guest


    I just switched to Ubuntu 13.04, and I can't get WebDAV work. I tried Dolphin, Gigolo, to mount via davsf2, and via Nautilus of course, none worked. I get the error message that say this share do not take care of webdav something like that.

    I tried to connect to my XenForo 1.1.4 set up then, and same errors : it's not because of XenForo 1.2 (work on none of them).

    Any ideas ? Maybe it's not a bug and because of me, but I really tried everything.

  2. Mike

    Mike XenForo Developer Staff Member

    In general, we only provide limited support for setting up the WebDAV system as it requires specific server configuration options and potentially particular programs. The first thing to check is that debug mode is enabled - it won't work with that. Then, you need to check that your server is happy passing on the WebDAV-specific HTTP methods (nginx may not be). Thirdly, you need to make sure that the HTTP auth headers are being sent through to PHP (some PHP configs may not do this by default).

    In general, it's tough to debug these unless you can see the full responses in your WebDAV client.
  3. account8226

    account8226 Guest

    Thanks for the awnser, I'm going to try to debug this.

    Debug mode is on, and I don't think it's because of the web servers since it was working before I moved to Ubuntu 13.

    I am able to view the templates files, but no way to save them :cry:.
  4. account8226

    account8226 Guest

    Hey Mike, still stuck, I tried so many things.

    On Ubuntu 13 contrary to Ubuntu 12, Nautilus is asking for the authentification after clicking the connect button, so in a second step. Don't you think XenForo needs that everything is sent in the first request (URL, protocol, user and password) ?
  5. Mike

    Mike XenForo Developer Staff Member

    Well the user and password are sent with every request, so I'm honestly not sure.
  6. account8226

    account8226 Guest

    Ok thanks, it's making me crazy : I can't develop without that.
  7. Luke F

    Luke F Well-Known Member

    Are you using nginx?
  8. account8226

    account8226 Guest

    I am using Apache 2, I don't think the problem is from the server.

    The main problem is from the client.
  9. account8226

    account8226 Guest

    After 24 hours of work, I finally got it working with davfs2. Thanks for the help.
    Mike likes this.
  10. Mike

    Mike XenForo Developer Staff Member

    Worth detailing what you needed to do should someone else run into this?
    Andrej likes this.
  11. account8226

    account8226 Guest

    Yes sure,

    So it seems that XF's webDAV's server is not working on Ubuntu 13 using Nautilus' client.

    For Ubuntu 12.04 :
    I had problems on Ubuntu 12 to get the client work I needed in nautilus to try to connect with the port as a random number -something else than 80, an error will occur, normal ^^-, and then connect to the traditionnal 80 port. Then everything will be ok and your template files will be shown in Nautilus.

    Ubuntu 13.04 :
    - Nautilus won't work, so I think using davfs2 is the best way to do it.

    1) You will need to mount XF's webdav with davfs2, there are a lot of tutorials on the internet (like that one : http://www.serverwatch.com/tutorial...essing-WebDAV-as-a-Filesystem-With-davfs2.htm).
    2) Once mounted, your template files will appear, you can edit them.

    But you'll maybe get a problem (impossible to write to the template files).

    To fix that :
    1) In /etc/fstab, make sure the line you added looks like that :
    http://localhost/xenforo-path/admindav.php/ /home/your_username/web-dav-path/webDAV-folder davfs user,gid=1000,uid=1000 0 0
    You must change the uid and gid with your's.
    To find a user id in Linux :
    id -u your-username
    To find a group id in linux :
    id -g your-username
    2) In $HOME/.davfs2/davfs2.conf, un-comment the following settings and change them to :
    use_locks 0
    use_expect100 1
    if_match_bug 1
    (add that to the end if you are not sure ;)).
    3) Ok, last thing, gedit is saving a temporary files before saving the main file. You need to disable that.
    In gedit -> edit -> settings -> editor -> untick "Create a backup before saving" (I forgot the exact words).

    It should be done, so that fix will allow you to use webdav in xenforo on Ubuntu 13, and save files one you have edited them (that was my problem).

    Best regards.

Share This Page