• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Importing problems from vBulletin 4

Sean James

Well-known member
#1
I am trying to convert a vBulletin 4.1.11 board to XenForo 1.1.2.

I tried Paul M's importer first which is no longer supported but it would halt on importing Blogs which then stopped me from importing attachments.

I am now trying this one:
http://xenforo.com/community/threads/vbulletin-4-to-xenforo-importer.27758/

I am having a problem when importing users:

Server Error

Mysqli prepare error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ON (user.userid = userfield.userid) STRAIGHT_JOIN vb_usertextfield AS usertex' at line 12
  1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
  2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
  3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
  4. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 734
  5. Zend_Db_Adapter_Abstract->fetchAll() in XenForo/Importer/vBulletin.php at line 756
  6. XenForo_Importer_vBulletin->stepUsers() in XenForo/Importer/Abstract.php at line 77
  7. XenForo_Importer_Abstract->runStep() in XenForo/ControllerAdmin/Import.php at line 180
  8. XenForo_ControllerAdmin_Import->_runStep() in XenForo/ControllerAdmin/Import.php at line 232
  9. XenForo_ControllerAdmin_Import->_startStep() in XenForo/ControllerAdmin/Import.php at line 175
  10. XenForo_ControllerAdmin_Import->actionStartStep() in XenForo/FrontController.php at line 310
  11. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
  12. XenForo_FrontController->run() in /home//changed/html/site/admin.php at line 13
I am thinking this might be caused by mySQL version?
 

Jake Bunce

XenForo moderator
Staff member
#4
# Zend_Db_Adapter_Abstract->fetchAll() in XenForo/Importer/vBulletin.php at line 756
This line number doesn't match for me. Can you confirm that you are running XF 1.1.2? Or maybe some of the files are bad.

Confirm your version and run a file check:

Admin CP -> Tools -> File Health Check
 

Sean James

Well-known member
#5
Hey Jake, thanks for taking the time to help mate.

When I run the file check i get this, this is a clean install of 1.1.2

File Health Check
Potential Problems

  1. library/XenForo/Importer/vBulletin.php File does not contain expected contents.
I am using the latest version of the importer.
 

Jake Bunce

XenForo moderator
Staff member
#6
Oh I see that importer package has you overwrite that file.

I found the relevant code in the modified importer. I don't see any obvious problems to explain the error.

I would like to know the complete query that is generating the error, but unfortunately the log you posted only shows part of the query. If you would like to give me FTP and admin access then I can debug the error to see what is going on.
 

Jake Bunce

XenForo moderator
Staff member
#8
I pulled the exact query that is returning the syntax error. The query is fine. It runs on my own vB database without error.

I think your hunch was correct. I think it's your MySQL configuration.
 

Sean James

Well-known member
#10
The vBulletin database is running on 4.1 and the new XenForo one is 5.0, could this also be a problem?

Host also says I should create a php5.ini file as this might fix the problem.

Please update the lines to point to the path of 3.3.9, the info in this article indicates 3.3.3.

Download Zend at http://www.zend.com/en/products/guard/downloads make sure to get the Linux version

'Using Zend Optimizer' may be helpful to you. Here's a link: Using Zend Optimizer.

Thanks,
Matt

 

Jake Bunce

XenForo moderator
Staff member
#11
The vBulletin database is running on 4.1 and the new XenForo one is 5.0, could this also be a problem?
Possibly. Though I don't see anything about the query that I recognize as being exclusive to MySQL5. But that query is being run against the vB database, not the XF database.