1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Importing Issue - Lost Many Posts

Discussion in 'Troubleshooting and Problems' started by fattony69, Mar 24, 2011.

  1. fattony69

    fattony69 Well-Known Member

    So I just recently imported my vBulletin forum and went live. The only issue for me is that I am missing threads and such. Some major threads too, not ones from years ago (which I wouldn't have minded as much.

    At first, I thought the decrease in posts and threads was like members (because they don't count if they are banned), but then I had members asking me where their threads are. With that, I tried re-importing my database multiple times to get back these threads. For some of them, I was able to get back certain threads, but it only overloaded the server because I did the import multiple times. Now, everyone's post count is three times what it should be, I am still missing about 45,000 posts (rough estimate since I realize that no matter what all posts should count towards the post count in XenForo. If that is the case, 45,000 makes sense since my Spam area was 33,000 posts big and I had 407,000 posts in vBulletin and I have only 395,000 posts now).

    With all this said, what should I do?
     
  2. Dean

    Dean Well-Known Member

    Probably the simplest thing would be to put in a support ticket.
     
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    If you will forgive the question... what evidence is there of missing threads? You say your members aren't able to find their threads. Where are they looking? It's important to confirm the problem and not just take your members at their word.

    With that said, you shouldn't rerun the same import multiple times on the same installation of xenForo. There is no easy way to deal with duplicate content from the previous import so you get problems like inflated user post counts. You should work with a new installation of xenForo (or even a backup of your xenForo database from before the initial import) if you want to run the import again.
     
    Kier likes this.
  4. mjp

    mjp Well-Known Member

    #1 rule of doing any kind of technical support. People will say that all kinds of things are haywire. Make them show you.
     
    Kier likes this.
  5. Dean

    Dean Well-Known Member

    I too was quite curious as to whether the missing threads were actually missing.
    Since he likes to keep his forum undisclosed, I suggested a support ticket. That way things could be handled more quickly.
     
  6. fattony69

    fattony69 Well-Known Member

    When members pointed it out to me, I personally search for them. I am sorry that I did not clarify that.

    That said, I probably shouldn't have rerun the same import which wasn't the best idea.

    I shall submit a support ticket. I was hoping there would have been an easy way to handle this.
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Did you rebuild the search index after the import?

    Admin CP -> Tools -> Rebuild Caches -> Rebuild Search Index
     
  8. fattony69

    fattony69 Well-Known Member

    Multiple times.
     
  9. yoghurtfarmer

    yoghurtfarmer Well-Known Member

    Back when xF was first released and I imported from SMF via vBulletin, the thread and post counts did not match up due to missing threads. I tracked down the missing threads, dug into the database to see what was common among them. In my case, the missing posts had an empty "posterusername" field so they ended up being omitted by the xF importer.

    Yours will likely be a different problem since you're importing straight from vB and since my import, the xF importer has gone through a number of revisions. The general idea is to track down the missing threads/posts and look in the database for any commonalities. My thread/post count pre and post import were identical FWIW.
     
    Dean and Jake Bunce like this.
  10. Dean

    Dean Well-Known Member

    I almost posted this yesterday. My first thought was possibly a language issue, but my guess would be the data and usernames would probably be english based on what I can tell. ( fattony69 has a firm grasp on English)
     

Share This Page