Importing from phpBB 3.3

TalonX

New member
I currently have a phpBB 3.3 forum and am considering migrating to XenForo for better features.

I see on this page in the docs that there it says there is an importer for phpBB 3.2 and I assume it should work for version 3.3, but I wanted to see if there are any upcoming changes to support a migration from phpBB 3.3 fully.

I've also seen threads saying that phpBB isn't a supported import and you'd have to import to version 1.5 and then upgrade. Can you confirm if this is the case, and whether there would be any additional cost for getting version 1.5 once I have a license for the latest version?
 

Mendalla

Well-known member
No, you don't need to use XF 1.5. There is now a phpBB importer for 2.x, per @Brogan last month in this thread.


Yes, there is a phpBB 3.2 importer available for XF2.

The only question would be whether there is a problem with using that importer with phpBB 3.3.
 

STNN

Active member
Ok, thanks for the info! I'll need to review what changes were made from 3.2 to 3.3 to see if it is usable as-is or will need some changes to make it work.

I imported from phpbb 3.2.2 just a few weeks ago using the 1.5 XF importer then upgraded to 2.1. It went flawless.

There will be a lot of <color, <i> bbcode like that which the importer fails to convert to xf bbcode. For some reason phpbb stored its posts in that format (with those html style tags).
 
Top