1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug Imported Custom Profile Fields do not display under avatar

Discussion in 'Resolved Bug Reports' started by Cooper, Oct 11, 2011.

  1. Cooper

    Cooper Active Member

    I added some custom field info from my old vbulletin into xf by inserting them into xf_user_field_value.

    The values appear fine in the users profile page but they do not appear under their avatar. If I go in and edit their profile and hit save, it suddenly appears and empty fields are created in xf_user_field_value for fields that are not being used by that user.

    Perhaps this is by design?

    Looking at above, if I insert '99' 'drives' 'Xantia TD' without the other records it doesn't appear under avatar.

  2. Russ

    Russ Well-Known Member

    My first non technical question would be did you enable them to be shown in style properties.
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I agree with Russ. Make sure these things are enabled:

    Admin CP -> Users -> Custom User Fields -> [click the field] -> General Options -> Viewable in message user info

    Admin CP -> Appearance -> Style Properties -> Message Elements -> Show custom user fields

    It is true that those records are not created until those fields are submitted somewhere for that user. For example, a newly registered user who registered on the front end will not have those records (unless those profile fields were set to show on the registration form). But the nonexistence of empty profile fields does not affect the display of others. I just tested and confirmed this.

    This is your problem. It won't work if you manually insert xf_user_field_value records because those values are also cached in xf_user_profile.custom_fields. Editing and saving a user in the Admin CP prompts a rebuild of this cache.

    Not a bug.
    WatchMan and Cooper like this.
  4. Cooper

    Cooper Active Member

    This was exactly it; rebuild of user caches has done the trick many thanks.

    Not a bug, apologies.

Share This Page