• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Import worked but noticed weird characters

#1
Briefing of what I did:

Migrated from MyBB 1.8.x
Old db type:
MyISAM
latin1_swedish_ci

XF db type:
InnoDB
utf8_general_ci

Issue is that these weird characters show up, seems like an encoding issue:
Code:
’ where an ' is supposed to be, i.e. But that’s not a bad thing

 for an extra space

“ for " (for first double quote?)
]†f for " (for ending double quote)
What would be the best way to address this? I've thought about downloading the affected tables and doing a search/replace via Notepad++ but am concerned that I might mess up the encoding like that or perhaps running a query on the affected tables but not sure what the appropriate query would be.

Thanks,
 

Mike

XenForo developer
Staff member
#2
In general, this needs to be resolved with a reimport. It can affect many tables. You probably need to set the database character set when starting the import to "latin1".
 
#3
Ah yes, I made the mistake of leaving the source as utf-8 when it wasn't...

However, I'm a bit confused as to the correct procedure of the reimport and the consequences of that.

Will I lose new data?

As for the process, when I go to Import Data do I basically just follow the same steps as the first time except change both the database charset and default language charset to latin1? Does the retain imported content IDs remain checked off?
 
#4
I ended up just redoing the import from scratch as I'm guessing that's what you meant anyway and it worked this time, I set the db charset to latin1 and the default to utf8. I set both to latin1 and it didn't work so I figured it out by trying yet again. Just dropping a note for anyone else who has this same issue.

Thanks for the latin1 tip in the import. If only I hadn't missed that the first time around...
 

Joe Blow

Active member
#5
I've got the same problem but it's way too late to do a re-import.

Can anyone advise if this approach will work for posts:

Code:
UPDATE xf_post SET message = REPLACE(message,'–','–');