• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed  Import problem: data too long for column 'last_thread_title'

dutchbb

Well-known member
#1
Code:
Server Error

Mysqli statement execute error : Data too long for column 'last_thread_title' at row 1

Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 574
Zend_Db_Adapter_Abstract->insert() in XenForo/DataWriter.php at line 1500
XenForo_DataWriter->_insert() in XenForo/DataWriter.php at line 1489
XenForo_DataWriter->_save() in XenForo/DataWriter.php at line 1291
XenForo_DataWriter->save() in XenForo/Model/Import.php at line 316
XenForo_Model_Import->_importData() in XenForo/Model/Import.php at line 685
XenForo_Model_Import->importForum() in XenForo/Importer/vBulletin.php at line 1372
XenForo_Importer_vBulletin->_importForumTree() in XenForo/Importer/vBulletin.php at line 1391
XenForo_Importer_vBulletin->_importForumTree() in XenForo/Importer/vBulletin.php at line 1391
XenForo_Importer_vBulletin->_importForumTree() in XenForo/Importer/vBulletin.php at line 1324
XenForo_Importer_vBulletin->stepForums() in XenForo/Importer/Abstract.php at line 77
XenForo_Importer_Abstract->runStep() in XenForo/ControllerAdmin/Import.php at line 161
XenForo_ControllerAdmin_Import->_runStep() in XenForo/ControllerAdmin/Import.php at line 213
XenForo_ControllerAdmin_Import->_startStep() in XenForo/ControllerAdmin/Import.php at line 156
XenForo_ControllerAdmin_Import->actionStartStep() in XenForo/FrontController.php at line 310
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
XenForo_FrontController->run() in /home/****/domains/mydomain.com/public_html/****/admin.php at line 13
My guess is our vB thread titles being too long for what's allowed in XF?
 

Mike

XenForo developer
Staff member
#2
I did see a report like this one before, but I'm not sure why it happens. It should be limiting the data length automatically.

Can you possibly send me the contents of your vB forum table?
 

dutchbb

Well-known member
#3
I did see a report like this one before, but I'm not sure why it happens. It should be limiting the data length automatically.

Can you possibly send me the contents of your vB forum table?
Sure, is there a way to send it privately? Since I rather not post data publicly. I tried a support ticket or conversation but it didn't have attachment option.
 

Mike

XenForo developer
Staff member
#11
Look for a couple references to "maxlength" in library/XenForo/DataWriter/Forum.php - it should be "maxLength" instead.