• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

MG 1.1 Import from vb 3.7 albums

#1
I performed a successful import back in August to XFMG 1.0 from vb 3.7 albums, to config and set up my forum.

I am now doing the final import before going live and I am getting an

Mysqli prepare error: Table 'v_albumupdate' doesn't exist

It's correct, the table doesn't exist. Is this something new in 1.1? Is there a workaround?

Panic is setting in... hoping to go live tonight. Thanks for your help!
 
#2
Nevermind, I think I got it. It looks like it was only referencing an update date in one place in XenGallery/Importer/
vBulletin38x.php. I removed the field select and the table join and it is happily importing, at least for now!
 

Chris D

XenForo developer
Staff member
#3
That's not really recommended...

You may be lucky, on this occasion, but in some cases doing similar things has the potential to ruin an entire import.

That said, the most concerning thing is that table being missing at all. That table is a vBulletin table, so at this point I would be concerned about the overall integrity of the data and whether any other tables are missing. I would certainly be more worried about that, than getting the import to continue. We haven't made any changes to the vBulletin importers for quite some time.
 
#4
Got it. And sure enough, I am getting a "Cannot save file /var/www/html/forums/internal_data/temp/xfmgT8PRl8" about 10% through my media import, although the albums came through properly.

I will check my backups for the missing table, and yeah, that is very concerning.

In a worst case situation, it is possible to copy the XFMG tables and data from my August import? I preserved the vb ID's. Darn. this went without a single hitch in August.
 
#6
I understand.

These importers are _amazing_ and I really appreciate the attention to detail you guys put into them, as well as the quick responses here.