1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Import Error

Discussion in 'Installation, Upgrade, and Import Support' started by Floyd R Turbo, Apr 7, 2015.

  1. Floyd R Turbo

    Floyd R Turbo Well-Known Member

    I'm encountering a mysterious error. I've had a custom conversion from DNN done and the XF end product looks good but has a few things that I didn't want to clean up manually.

    So I did a clean XF1.4.5 install and started to import the conversion (which is in 1.4.5). When I go to import threads, it gets to 94.33% (about 8-9 minutes in) and then I get "Error. Please enter a valid value."

    I've looked at the xf_post table and discovered some weird conversion errors that resulted in photos being translated into text (tens of thousands of characters long) and manually deleted the content of those posts out of the table. That didn't do it.

    I haven't looked at the xf_thread table but I suppose I should, to see where it stops. I'm guessing there is an invalid post title or some invalid post content that is causing the import to error out. Otherwise, the import seems to be fixing the issue I was trying to avoid fixing manually, and also since this is causing this error now, it is potentially relieving an future issue...so it's a good thing I tried it.

    Any insight as to what might be causing this error or where to look would be appreciated.

    I have no errors in the server log.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Look at the last records in the tables and that should give you an idea as it will be erroring on the next one.
  3. Floyd R Turbo

    Floyd R Turbo Well-Known Member

    I'm pretty sure I'm a moron here. I'll know in about an hour...
  4. Floyd R Turbo

    Floyd R Turbo Well-Known Member

    Either that, or there is a big conversion error.
  5. Floyd R Turbo

    Floyd R Turbo Well-Known Member

    Well, it's not me. It's stopping at the exact same place. I had a prior conversion done as a dry run, and I thought maybe I had grabbed the wrong database for the import but that wasn't it. I also thought I might have grabbed the wrong backup of the XF installation, but that wasn't it either.

    There doesn't seem to be anything out of the ordinary about the line in xf_thread for the thread in question. There is nothing out of the ordinary, as far as I can tell, about the post in particular either.

    I'm lost.
  6. Floyd R Turbo

    Floyd R Turbo Well-Known Member

    process of elimination: I deleted the thread that it errored out on (the next one that it would have imported) and ran it again, that wasn't it. Stopped at the same spot (imported the same last thread).

    So maybe now I delete the last thread that is successfully imports and run it again?

    Is there some other table that it could be erroring out on?
  7. Floyd R Turbo

    Floyd R Turbo Well-Known Member


    This time, I deleted the thread right after the error point (thread #22082, single post), as well as the last thread that successfully converted (thread #22081, which was about 5-8 posts) and ran the import.

    This time, it successfully imported up to the next thread (#22083, about 10-11 posts).

    Then, error.

  8. Floyd R Turbo

    Floyd R Turbo Well-Known Member

    The part that is so frustrating here is that the forum as converted works just fine - no errors, no problems. I can see all threads. So why would this be happening. Maddening.
  9. Brogan

    Brogan XenForo Moderator Staff Member

    It's going to be a thread or post record which doesn't contain the expected data.

    Try comparing the entire row with a valid thread/post to see if there is anything unusual or different about it.
  10. Floyd R Turbo

    Floyd R Turbo Well-Known Member

    I can't find anything particularly odd about any thread or post near the error point. I've deleted the threads on either side of the error point (via the forum, not directly in the database) and that doesn't prevent it from happening. I rebuilt all the caches and it still happens.
  11. Floyd R Turbo

    Floyd R Turbo Well-Known Member

    The xf_post table that I am importing has about 180,000 posts. It gets to about 172,000 and that's where it errors out.

    In looking at the xf_thread table after the error, it has populated the first half of all rows but everything past discussion_type appears to be zeroed out, is this normal, i.e. does this get filled in on the next step? The info is in the source table (guessing it's a matter of rebuilding everything after import)

    Not to go off topic but I tried to import convos and that made it through (about 175,000 messages), when I looked at the tables though there are messages missing. I haven't taken the time to figure out which ones are gone, that's a whole 'nother issue.

    My concern is that if I ever, in the future, need to do an import, that's when this is going to rear it's ugly head. I would prefer to have it to a point where everything cleanly imports from XF to XF so that I know, at least, I'm starting out good.

    But in reality, if I have a fully operating installation and no problems currently - just problems importing XF to XF - do I just not worry about it?
    nghiadv likes this.
  12. Floyd R Turbo

    Floyd R Turbo Well-Known Member

    Well after I found a series of issues, I decided to take the original converted database and import that and it flew through with flying colors.

    So, it turns out that it's my fault. And I think I know why. DNN uses a "username" and "displayname" filed for each user. I wanted the display name field and they used the username field. So I swapped it out post conversion and didn't catch a duplicate field because I didn't look for different-case duplicate names. So xf_user had a duplicate username and when I rebuilt the table at some point, it eliminated the duplicate and well there you go.

    Lesson learned. This conversion is a total pain in the $&@. But at least I know now that it wasn't the conversion company's error.
  13. Brogan

    Brogan XenForo Moderator Staff Member

    That's the first time you have mentioned that.

    That information is critical to the issue and would have been useful from the start.
  14. Floyd R Turbo

    Floyd R Turbo Well-Known Member

    Yeah, I know - sorry...I didn't know that there was a duplicate username until literally 10 minutes before I made that post.

    I had a dry-run conversion done 6 months ago, swapped out the usernames in the table, and performed a myriad of test and there were no problems with anything at all. The one thing that I had not performed was an import, so I never saw this issue. The conversion company was supposed to use the displayname table so I didn't worry about my "hacks" as I thought I would not have to use them, but they didn't listen as well as I had hoped the second time around and I was forced to use my hack again.

    I still find it strange that the import stops at this point, now that I've identified the issue I'll have to look at the table data and see what's going on. I'm guessing that if there were users named "Mike" and "mike" that one just 'went away' and when one of the missing user's post were encountered, this is when things went wacky.

Share This Page