• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 import error from phpbb3

#1
Importing of user groups worked, Import of custom user fields where good.

Went to import users and got the following error. I thought it might be a duplicate entry but I can't find anything with '2' for an email address or username.

Any ideas?

Server Error
Mysqli statement execute error : Duplicate entry '2' for key 'PRIMARY'

  1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
  2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
  3. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 574
  4. Zend_Db_Adapter_Abstract->insert() in XenForo/DataWriter.php at line 1612
  5. XenForo_DataWriter->_insert() in XenForo/DataWriter.php at line 1601
  6. XenForo_DataWriter->_save() in XenForo/DataWriter.php at line 1393
  7. XenForo_DataWriter->save() in XenForo/Model/Import.php at line 804
  8. XenForo_Model_Import->importUser() in XenForo/Importer/PhpBb3.php at line 1000
  9. XenForo_Importer_PhpBb3->_importUser() in XenForo/Importer/PhpBb3.php at line 823
  10. XenForo_Importer_PhpBb3->_importOrMergeUser() in XenForo/Importer/PhpBb3.php at line 612
  11. XenForo_Importer_PhpBb3->stepUsers() in XenForo/Importer/Abstract.php at line 97
  12. XenForo_Importer_Abstract->runStep() in XenForo/ControllerAdmin/Import.php at line 187
  13. XenForo_ControllerAdmin_Import->_runStep() in XenForo/ControllerAdmin/Import.php at line 239
  14. XenForo_ControllerAdmin_Import->_startStep() in XenForo/ControllerAdmin/Import.php at line 182
  15. XenForo_ControllerAdmin_Import->actionStartStep() in XenForo/FrontController.php at line 347
  16. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  17. XenForo_FrontController->run() in /home/wdw360/public_html/forums/admin.php at line 13
 
#2
So i put a fresh install on with no users or configured people and I was able to import it. Looks like the issue was with something existing already on the forum i configured.
 

Jake Bunce

XenForo moderator
Staff member
#3
When you enable the option to preserve source ids (at the beginning of the import), the forum must be brand new (no users, groups, nodes, etc created), otherwise you will get that 'duplicate entry' error.