1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Image Upload Issue

Discussion in 'Troubleshooting and Problems' started by TheSalt, Oct 16, 2014.

  1. TheSalt

    TheSalt Active Member

    Hello Gang!

    I have a new issue. I had a user tell me they are having an issue uploading images. I looked into attachment size and it is set to just over 3mb on the ACP. I tested with an image that was 3mb and I got the same error. It looks to be a server error as it states. I searched around here and only found threads with people that have a VPS and I'm on a shared server at godaddy still. Also I'm not seeing any error logs on the ACP or server but I could be doing something wrong. Any ideas?

    Many Thanks,
    Nick

    Screen Shot 2014-10-15 at 4.36.30 PM.png
     
  2. Tracy Perry

    Tracy Perry Well-Known Member

    Contact your host and relate the error to them. I know with nginx it involves the vhost settings and PHP processor settings on restrictions on maximum file size.
     
  3. TheSalt

    TheSalt Active Member

    Thank you Tracy! I'll give them a call. I hope you are well friend. :)
     
  4. TheSalt

    TheSalt Active Member

    Hello Gang!

    I got it worked out. there is a file in the root or public_htlm named php.ini that has a upload mas too. In my file it was line 476 and the line should read as shown below. All you have to do is adjust the 2m to whatever file you want to allow for.

    A side note I was told I need to make a php.ini file to begin with but after I saw that there was one already I seeked out the max. Again it was in line 476 but you can just search your php.ini file for the line below as well. After making the adjustment it can take a few minutes to take place. I would suggest backing up the original php.ini file before you make any changes as well. I hope this help someone else down the road.

    PHP:
    upload_max_filesize 2M
     

Share This Page