1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Image Proxy Cron Error

Discussion in 'Troubleshooting and Problems' started by OakleyForum, Oct 1, 2016.

  1. OakleyForum

    OakleyForum Active Member

    Seeing a large number of these errors in my AdminCP, any thoughts?

    ErrorException: Fatal Error: Call to undefined method XenForo_Model_ImageProxy::pruneImageReferrerLogs() - library/XenForo/CronEntry/CleanUp.php:68
    Generated By: Unknown Account, Today at 5:10 PM
    Stack Trace
    #0 [internal function]: XenForo_Application::handleFatalError()
    #1 {main}
    Request State
    array(3) {
      ["url"] => string(39) "http://www.oakleyforum.com/deferred.php"
      ["_GET"] => array(0) {
      ["_POST"] => array(3) {
        ["_xfRequestUri"] => string(44) "/threads/oakley-lens-cleaning-solution.9047/"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfResponseType"] => string(4) "json"
  2. Chris D

    Chris D XenForo Developer Staff Member

    That would certainly be unusual.

    This could be that the file is missing or doesn't contain the expected contents.

    So, first thing to check is the File Health Check in Admin CP > Tools > File Health Check.

    If that is all ok, then it could actually be caused by an add-on that hasn't extended the ImageProxy model class properly.

    To test this, you should edit your config.php and enable debug mode:
    $config['enableListeners'] = false;
    Once you've done that, try and re-run the Hourly clean up cron to see if that gives you any errors. Admin CP > Tools > Cron Entry > Hourly Clean Up > Controls > Run.
  3. OakleyForum

    OakleyForum Active Member

    Did this and received the same error essentially: "
    Fatal error: Call to undefined method XenForo_Model_ImageProxy::pruneImageReferrerLogs() in /home/oakleyfo/public_html/library/XenForo/CronEntry/CleanUp.php on line 68"
  4. Chris D

    Chris D XenForo Developer Staff Member

    Does this come back ok?

    What XF version are you running?
  5. OakleyForum

    OakleyForum Active Member

    Came back with several files which did not match contents - including image proxy - replaced with 1.5.7 version files (current version I'm running) and it appears to have fixed it.

    Chris D likes this.

Share This Page