• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Image Error in Error Log. Please help!

#1
Just checked my error log and realized I have insane amounts of errors:

ErrorException: imagejpeg() [<a href='function.imagejpeg'>function.imagejpeg</a>]: gd-jpeg: JPEG library reports unrecoverable error: - library/XenForo/Image/Gd.php:208
Can someone help?
 

Jake Bunce

XenForo moderator
Staff member
#3
Does that happen with all jpg uploads? Or perhaps it's just for one particular jpg image that is corrupt?

If it happens with all jpgs then it must be a problem with your image library in which case you should upgrade GD or install ImageMagick on your server.
 
#4
It was a problem with all images. I disable the LightBox add-on I had and added a resizing property to my css, which helped a little. Before, photobucket images weren't showing up, they were showing as question marks, then when you clicked on it it showed you the large photo from photo bucket. After disabling Lightbox, it shows pictures, but I am still getting the errors.

And the errors are for most images. I will try updating GD or installing IMageMagick. Do you have instructions on how to update/install them?
 
#7
Just realized this is still occuring with imagemagick installed. Here is the error
ErrorException: imagejpeg() [<a href='function.imagejpeg'>function.imagejpeg</a>]: gd-jpeg: JPEG library reports unrecoverable error: - library/XenForo/Image/Gd.php:208
Generated By: Unknown Account, Today at 2:52 PM
Stack Trace
#0 [internal function]: XenForo_Application::handlePhpError(Resource id #17, NULL, 85)
#1 /home/kal811/public_html/library/XenForo/Image/Gd.php(208): imagejpeg(2)
#2 /home/kal811/public_html/image.php(71): XenForo_Image_Gd->output()
#3 {main}
Request State
array(3) {
["url"] => string(128) "http://www.oakleyforum.com/image.ph...iza702baby/WP_000966.jpg&width=640&height=480"
["_GET"] => array(3) {
["url"] => string(66) "http://i522.photobucket.com/albums/w341/ibiza702baby/WP_000966.jpg"
["width"] => string(3) "640"
["height"] => string(3) "480"
}
["_POST"] => array(0) {
}
}
Can anyone help?