• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

I'm getting 404 errors thrown at me left and right!

Disrelation

Active member
#1
I just installed XenForo on my CentOS VPS. The installation went well although I had a few things to correct during the process and I noticed that when I was doing the installation, it asked me to save the config file and than press continue once I did, I pressed continue and it said it could not find the config file. I than went ahead and put the saved config file I downloaded into the correct directory and it went ahead.

Now, I can access the Admin CP but if I try to access anything on the front-end of the forum, it shoots me a 404 error. I can see the homepage (the board is currently closed) and I am not logged in, but if I attempt to log in or click "Members" in the navigation or "Help", I find myself with a 404 error.

How can I fix this?! :(
 

Jake Bunce

XenForo moderator
Staff member
#2
Are you using friendly URLs?

Admin CP -> Home -> Options -> Search Engine Optimisation (SEO) -> Use Full Friendly URLs

If this is enabled then be sure the .htaccess file is in place:

http://xenforo.com/help/friendly-urls/

Apache

Apache is the most common web server available. If you are unsure what web server you are running, it is likely Apache. Therefore, XenForo includes the necessary configuration file in the root directory.

If after uploading XenForo, you do not see a ".htaccess" file in your XenForo root directory, rename htaccess.txt to .htaccess (be sure to include the "." prefix). You should now be able to enable friendly URLs. If, after enabling friendly URLs your XenForo installation does not function correctly, please contact your host to confirm that they have mod_rewrite installed and allow overrides via a .htaccess file.