Icewind Staff [Deleted]

iZeroLogic

Member
Although this add-on is coded for the secondary user group, will there be an option to have it work for the primary user group. I've read on your earlier post about the Xenforo manual recommending the secondary user group method, sadly I have all my staffs user group all set under primary. If anything, I may just revise all my group permissions. :D
 

RobinHood

Well-known member
Great update to the old add on Lawrence, works great :)

One suggestion for improvement would be the ability to optionally add a usergroup tab to the notable members page like this:

upload_2015-1-4_14-55-26.png
 

Zyenaux

New member
Is there a way to edit the "Notable Members" tabs/pagigation" and allows you to customize the subtabs, i dont understand how to, so i may create a "staff or management" team tab. Sorry to bother!
 
Last edited:

Lawrence

Well-known member
Is there a way to edit the "Notable Members" tabs/pagigation" and allows you to customize the subtabs, i dont understand how to, so i may create a "staff or management" team tab. Sorry to bother!

No bother, :) I'm not sure what you are asking, can you post a screen shot, that shows what you would like to accomplish?
 

Zyenaux

New member
Well, you know the "Staff Members" tab in Notable Members?
I was wondering if i could link that to my own page, using this staff addon.

I solved my previous issue, this is something diffrent :p
 

Lawrence

Well-known member
Well, you know the "Staff Members" tab in Notable Members?
I was wondering if i could link that to my own page, using this staff addon.

I solved my previous issue, this is something diffrent :p
The add-on can remove the Staff Members tab from the Notable Members page. You can create a new staff list, but it can only be placed on the Nav Bar, or under the Member's tab. You can place it under the Members Tab and set the Staff Online link in the sidebar to point to your new staff page (this is an option under Staff, it will only allow you to select public tabs).

I'll look at adding another option to allow Staff tabs to be placed with the Notable members page the next time I look at this add-on, :)
 

Lawrence

Well-known member
Why are some of my tabs not displaying members even though they're in the specified usergroup?

This add-on works off of secondary user groups. All members, including Admins and Moderators, should have their primary user group set to Registered, and any other group they may belong to should be added as a secondary group. This is how user groups are intended to work, so this is how the Staff add-on works, :)
 

Sgreefers

Member
I have the following server errors. Might helping me out?

Error Info
ErrorException: Undefined offset: 1 - library/Icewind/Staff/Route/Prefix/Tabs.php:18
Generated By: Unknown Account, 58 minutes ago

Stack Trace
#0 /var/www/vhosts/sgreefers.com/httpdocs/library/Icewind/Staff/Route/Prefix/Tabs.php(18): XenForo_Application::handlePhpError(8, 'Undefined offse...', '/var/www/vhosts...', 18, Array)
#1 /var/www/vhosts/sgreefers.com/httpdocs/library/XenForo/Route/Prefix.php(86): Icewind_Staff_Route_Prefix_Tabs->match('', Object(Zend_Controller_Request_Http), Object(XenForo_Router))
#2 /var/www/vhosts/sgreefers.com/httpdocs/library/XenForo/Route/Prefix.php(66): XenForo_Route_Prefix->_loadAndRunSubRule('Icewind_Staff_R...', '', Object(Zend_Controller_Request_Http), Object(XenForo_Router))
#3 /var/www/vhosts/sgreefers.com/httpdocs/library/XenForo/Router.php(72): XenForo_Route_Prefix->match('sgreefers-team/', Object(Zend_Controller_Request_Http), Object(XenForo_Router))
#4 /var/www/vhosts/sgreefers.com/httpdocs/library/XenForo/Dependencies/Abstract.php(107): XenForo_Router->match(Object(Zend_Controller_Request_Http), NULL)
#5 /var/www/vhosts/sgreefers.com/httpdocs/library/XenForo/FrontController.php(285): XenForo_Dependencies_Abstract->route(Object(Zend_Controller_Request_Http), NULL)
#6 /var/www/vhosts/sgreefers.com/httpdocs/library/XenForo/FrontController.php(130): XenForo_FrontController->route()
#7 /var/www/vhosts/sgreefers.com/httpdocs/index.php(13): XenForo_FrontController->run()
#8 {main}

Request State
array(3) {
["url"] => string(35) "http://sgreefers.com/sgreefers-team"
["_GET"] => array(0) {
}
["_POST"] => array(0) {
}
}
 

popowich

Active member
I can't mark a post as spam anymore. The option is missing. My last change was installing this add-on about a week ago. Has anyone else had this problem? Disabling doesn't fix the problem. Didn't try a complete uninstall yet.
 

popowich

Active member
I can't mark a post as spam anymore. The option is missing. My last change was installing this add-on about a week ago. Has anyone else had this problem? Disabling doesn't fix the problem. Didn't try a complete uninstall yet.

The suggestion in this post fixed the problem for me - XF 1.4 - Moderators don't see ban & spam options for all users

I don't understand what changed though. I didn't edit the options to make them 30/30/5. Setting to 0/0/0 did fix it so I can see the Spam link in posts again.
 

Lawrence

Well-known member
I can't mark a post as spam anymore. The option is missing. My last change was installing this add-on about a week ago. Has anyone else had this problem? Disabling doesn't fix the problem. Didn't try a complete uninstall yet.

A little late, but... the staff add-on has nothing to do with spam, it just displays members of select user groups.

As a note, I won't be adding any more features to this add-on as I won't need it for my site anymore. I'm replacing it with my roster add-on. One of the differences is that the roster add-on doesn't use custom routes based off of the category name, it just uses the one (rosters), but it can be changed via a route filter. As there is only one route everything falls under the roster tab.
 

Lawrence

Well-known member
Hi nice addon, but it doesn't show the users that are in that usergroup?

Thanks, :) Which user group are you referring? This add-on works off of secondary user groups.

My roster add-on, which I am not sure of when it will be released, takes the primary user group into the mix as well.
 

Zaino60

Member
Update to XF 1.5 please, as it doesn't actually work:
b0a08e85d01703388ac2f78515f66e8c.png
 
Top