1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Icewind Dale RP Total Forum Thread Views [Deleted]

Discussion in 'Add-on Releases' started by Lawrence, Dec 22, 2012.

  1. Lawrence

    Lawrence Well-Known Member

    Lawrence submitted a new resource:

    Icewind Dale RP Total Forum Thread Views (version 1.0) - Tallies all message views, and displays the total in the Sidebar and on each Forum.

    Read more about this resource...
     
    Lê Tí, SchmitzIT and Chris D like this.
  2. DRE

    DRE Well-Known Member

    wtf

    This only does it from scratch. *uninstalls*

    Thanks anyway!
     
  3. Lawrence

    Lawrence Well-Known Member

    I'm not sure what you mean from scratch? After you install it go to tools and rebuild the cache to get the initial totals. You do not need to run the cache rebuilder again. The cron will update the counts with the new views twice an hour.
     
  4. James

    James Well-Known Member

     
  5. Sheldon

    Sheldon Well-Known Member

    Great work Lawrence, thanks.

    Appreciate you adding in as phrases too!

    mviews.png

    Juts gotta figure out something "Zombie-ish" to change it to... hahahaha.
     
  6. Mark3121

    Mark3121 Well-Known Member

    So every time someone clicks into a thread its +1 or unique views?
     
  7. Lawrence

    Lawrence Well-Known Member

    Works the same way as the standard thread views work. Each time a thread is viewed that forums total views increases by 1.
     
    Mark3121 likes this.
  8. Jeff Fuqua

    Jeff Fuqua Well-Known Member

    Nice add-on. Any way to incorporate commas into the number format?

    example: 1000000 becomes 1,000,000
     
  9. Lawrence

    Lawrence Well-Known Member

    Thanks.

    As for the comma's I figured <xen: number...> took care of that. Ug :)

    Edit: just remembered that in the forum list I couldn't use my own template, as the hook passed no data, and never thought about number formatting with the work around I used. Again, ug.
     
  10. Lawrence

    Lawrence Well-Known Member

    Lawrence updated Icewind Dale RP Total Forum Thread Views with a new update entry:

    Added number formatting for the forums views

    Read the rest of this update entry...

    If you downloaded and installed v1.0, you do not need to re-install the package, down load the template.zip file found in the post below, extract it and upload template.php to yourXenForo/library/IcewindDaleRP/ForumThreadViews/Listener/ Be sure it over-writes the existing template.php file.
     

    Attached Files:

    Jeff Fuqua and Sheldon like this.
  11. Sheldon

    Sheldon Well-Known Member

    Worked for me! (y)
     
    Lawrence likes this.
  12. Lê Tí

    Lê Tí Member

    Nice add-on
     
  13. Luxus

    Luxus Well-Known Member

    I can afford it. Where can I send you the money? (j/k)
     
    Lawrence likes this.
  14. Lawrence

    Lawrence Well-Known Member

    Thanks for the verification. :)
     
  15. oman

    oman Well-Known Member

    Great add on Lawrence. Thanks for the easy installation instructions as well!
     
  16. Adam Howard

    Adam Howard Well-Known Member

    re-packaged to work with auto install / updater
     

    Attached Files:

    Chris D likes this.
  17. Adam Howard

    Adam Howard Well-Known Member

    Not really a problem .... But will note of down for keep sake

    PHP:
    ErrorExceptionUndefined indexforum library/IcewindDaleRP/ForumThreadViews/ControllerPublic/Thread.php:13
    Generated By
    Adam4 minutes ago
    Stack Trace

    PHP:
    #0 /home/*****/public_html/forums/library/IcewindDaleRP/ForumThreadViews/ControllerPublic/Thread.php(13): XenForo_Application::handlePhpError(8, 'Undefined index...', '/home/*****/...', 13, Array)
    #1 /home/*****/public_html/forums/library/XenForo/FrontController.php(310): IcewindDaleRP_ForumThreadViews_ControllerPublic_Thread->actionIndex()
    #2 /home/*****/public_html/forums/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #3 /home/*****/public_html/forums/index.php(13): XenForo_FrontController->run()
    #4 {main}
    Request State

    PHP:
    array(3) {
      [
    "url"] => string(95"http://www.sociallyuncensored.eu/forums/threads/addicts-and-siblings-share-brain-features.12886"
      
    ["_GET"] => array(0) {
      }
      [
    "_POST"] => array(0) {
      }
    }
     
  18. Adam Howard

    Adam Howard Well-Known Member

    I honestly don't know.... It was a double post, so I deleted that thread, but I also moved it. The remain thread works fine and it is only the crawling bots that are looking for the old moved & deleted link that seem to bump into that.

    I'm not able to repeat the error, but if I try to visit that link I do get the error. :confused:

    As I said... Don't think it's an issue (not really). More of an odd mystery. :cautious:
     
  19. Lawrence

    Lawrence Well-Known Member

    It's a redirection error, forum id's are not set when there is a redirection. I have it fixed on my site.
     
  20. Adam Howard

    Adam Howard Well-Known Member

    Can we expect that fix? (please)
     

Share This Page