• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Icewind Clone User Group [Deleted]

Lawrence

Well-known member
#1
Lawrence submitted a new resource:

Icewind Clone User Group - Quickly create a User Group based of another one

What it Does:
This simple add-on does what the name implies: allows admins to clone another user group. It copies permissions, CSS, and any banner settings you may have set in the user group you want to clone. Select the clone link, enter a new title for the user group and press the Save User Group button.

This add-on does not copy user group node permissions.

Template Edits:
None

Template Modifications: 1 modification to the admin user_group_list template...
Read more about this resource...
 

CFodder

Well-known member
#5
Great work Lawrence, I'm somewhat baffled that either of these copy/clone functions aren't in the core ... but as stated by yavuz am happy to have them as addons :).
 

Lawrence

Well-known member
#7
Not showing up on 1.3 (just installed this)
I just installed it on a freshly installed 1.3, and the links to clone the groups show. The links are displayed here: User Groups -> List User Groups. If that is where you are looking for the Clone Links and they are not listed to the far right of each listed user group then there may be another add-on installed that is interfering with the Admin Template Modifications for the user_group_list template.
 
#8
I get this error when I install it

Callback Icewind_CloneUserGroup_Listener_FileHealthCheck::getIwdCloneUserGroupHashes is invalid (Invalid Class).

Any ideas?
 

Lawrence

Well-known member
#9
I get this error when I install it

Callback Icewind_CloneUserGroup_Listener_FileHealthCheck::getIwdCloneUserGroupHashes is invalid (Invalid Class).

Any ideas?
Just so happens I recently cleaned up my dev site so I can work on my roster add-on with an out-of-the-box copy of XF. I just installed the Clone User Group add-on to try to replicate your issue. It installed correctly, and I also ran the file health check. I would say that the files were corrupted when uploaded and should be uploaded again, :)
 

Lawrence

Well-known member
#12
Thanks. When user groups are set correctly this add-on is a real time saver. The best part is that you do not need a separate tab opened or an excel document opened to keep track of permissions, as this shows you exactly what permissions the user group that you are cloning has, so you can set the new ones accordingly and never be concerned with duplicate permissions.

Combined with my clone node add-on, you can create a forum for a specific user group to access in less than a minute, a big time saver for those with guilds and the such.
 

Blast

Active member
#13
Exactly. You have no idea how much time I've lost opening up 2 windows, and just keep on alt-tabbing just to make sure I get the same exact permissions. In my community, there are groups that share the same exact permissions but have different names.
 

snoopy5

Well-known member
#15
Hi

XF 1.5.12 I installed this addon without problems. The clone button appears in ACP. Cloning works with normal userrights.

BUT if you have a forum which has restricted access, you need to add there again all rights in ACP/ Applications/ Node Tree/ Permissions and then click on your cloned usergroup to make the settings manually.

These are not copied with the clone addon from one usergroup to the clone.
 

Lawrence

Well-known member
#16
Hi

XF 1.5.12 I installed this addon without problems. The clone button appears in ACP. Cloning works with normal userrights.

BUT if you have a forum which has restricted access, you need to add there again all rights in ACP/ Applications/ Node Tree/ Permissions and then click on your cloned usergroup to make the settings manually.

These are not copied with the clone addon from one usergroup to the clone.
Hi, this only clones usergroups. Have you tried my Clone Node add-on?