1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I need help with ES

Discussion in 'Enhanced Search Support' started by tafreehm, Apr 29, 2013.

  1. tafreehm

    tafreehm Well-Known Member

    I have just installed ES and rebuild all search index. Now when I try to perform any search it return 0 results. I may have missed something but cannot figure out what that is.

    In admincp > options > Search Options :
    I am not sure what values to fill up there. I have left them as default and checked 'enable elastic search'.

    Please tell me how to fix that. Thanks
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. The Forum Heroes

    The Forum Heroes Well-Known Member

    We have several other clients on the same server using ES. None of them required any server details, they just used default info and then rebuilt search index.
  4. tafreehm

    tafreehm Well-Known Member

    One more thing: under Tools > ElasticSearch Setup it still says "The search index should be rebuilt immediately after changing any values on this page."

    Does it supposed to go away after you rebuilt search indexes, or it stays there forever ?
  5. tafreehm

    tafreehm Well-Known Member

    I found this in error logs:

    Server Error Log
    Error Info
    XenForo_Exception: Elasticsearch error: IndexMissingException[[mella_db] missing] - library/XenES/Search/SourceHandler/ElasticSearch.php:713
    Generated By: Don, Today at 8:30 PM
    Stack Trace
    #0 /home/mella/public_html/library/XenES/Search/SourceHandler/ElasticSearch.php(200): XenES_Search_SourceHandler_ElasticSearch->_logSearchResponseError(Object(stdClass), true)
    #1 /home/mella/public_html/library/XenForo/Search/SourceHandler/Abstract.php(115): XenES_Search_SourceHandler_ElasticSearch->executeSearch('first post', false, Array, Array, false, '200')
    #2 /home/mella/public_html/library/XenForo/Search/Searcher.php(79): XenForo_Search_SourceHandler_Abstract->searchGeneral('first post', Array, 'date', '200')
    #3 /home/mella/public_html/library/XenForo/ControllerPublic/Search.php(230): XenForo_Search_Searcher->searchGeneral('first post', Array, 'date')
    #4 /home/mella/public_html/library/XenForo/FrontController.php(310): XenForo_ControllerPublic_Search->actionSearch()
    #5 /home/mella/public_html/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #6 /home/mella/public_html/index.php(13): XenForo_FrontController->run()
    #7 {main}
    Request State
    array(3) {
      ["url"] => string(41) "http://www.forum.com/search/search"
      ["_GET"] => array(0) {
      ["_POST"] => array(4) {
        ["keywords"] => string(10) "first post"
        ["users"] => string(0) ""
        ["date"] => string(0) ""
        ["_xfToken"] => string(8) "********"
  6. AndyB

    AndyB Well-Known Member

    It stays there.
    tafreehm likes this.
  7. AndyB

    AndyB Well-Known Member

    Verify your Xenforo database name is shown here (red arrow).


    Assuming it is, I suggest checkmarking the Delete Index and clicking Delete Index. That will delete your index and create a new mapping. At that point you need to rebuild the Search Cache.

    Admin CP -> Tools -> Rebuild Caches -> Rebuild Now
    tafreehm likes this.
  8. tafreehm

    tafreehm Well-Known Member

    yes it was there....
    ok here is what is happening now. All the subsequent posts are returning in search result but the older ones. That means search index was not built properly.
    I am gonna use option 'delete index' as AndyB suggested and rebuild search index.
  9. tafreehm

    tafreehm Well-Known Member

    I tried that just now, and it did not change anything... :(
  10. AndyB

    AndyB Well-Known Member

    I assume during the search index rebuild it did show the posts and threads and other info as it was being rebuilt?

    What happens if you create a new message and enter in a unique word like test1234, does the search find it?
  11. tafreehm

    tafreehm Well-Known Member

    thank you for the help.. and yes it was doing that and magically it have started to work normal now. However, there is one keyword that I have been using for test search does not return anything but one post. and I am 120% sure that there are thousands of posts that has that keyword.

    Can someone explain me this behavior ?
  12. AndyB

    AndyB Well-Known Member

    What is the search word you are entering?
  13. tafreehm

    tafreehm Well-Known Member

    Update: I just tried and it works fine as well.
  14. AndyB

    AndyB Well-Known Member

    Good to hear it's working now.
  15. tafreehm

    tafreehm Well-Known Member

    Thank you so much for all the help :) Much appreciated.

Share This Page