• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

I moved to new server and I have error An unexpected database error occurred. Please try again later

#1
I moved to new server and i have this error An unexpected database error occurred. Please try again later.

source code is just this code An unexpected database error occurred. Please try again later.

do u know how can i solve this problem?

New server is same as old one?

I moved with full cpanel backup so there is no mistake
 
F

Floris

Guest
#2
Confirm the files are there.
Confirm the database is there (and populated)
And confirm the data in config.php is accurate and up to date.

If the new server doesn't use APC or other caching, but your config has been set to cache, turn it off.

Check ownership on the files, and their permissions.

chmod -R internal_data/
chmod -R data/

In case this is needed as well.

Check if the .htaccess file(s) are there.

Check the php/mysql version, did you down or upgraded them?

Turn on debug mode and load the page again, see if you get any further details.
http://xenfans.com/threads/how-to-turning-on-debug-mode.7/

Check the error log file on the server to see what the server is complaining about.

Best of luck
 

Brogan

XenForo moderator
Staff member
#4
If you are convinced all of the data is correct, then run the compatibility script.
Although I presume you checked that before switching servers?

XenForo System Requirements
  • PHP: 5.2.4+
  • MySQL: 5.0+
  • PHP extensions: MySQLi, GD (with JPEG support), PCRE, SPL, SimpleXML, DOM, JSON, iconv, ctype
  • PHP safe_mode off
Download the requirements test script.

You could also try restarting the server.
 
#6
Also view the source code of the error page. That should reveal a more detailed error message.
in the source code there is nothing just the same error is writing

It is still same I did everything my website is dying now:( I dont know how can I fix it
If you are convinced all of the data is correct, then run the compatibility script.
Although I presume you checked that before switching servers?

XenForo System Requirements
  • PHP: 5.2.4+
  • MySQL: 5.0+
  • PHP extensions: MySQLi, GD (with JPEG support), PCRE, SPL, SimpleXML, DOM, JSON, iconv, ctype
  • PHP safe_mode off
Download the requirements test script.


You could also try restarting the server.
I tried

Requirements Met

Your server meets all of XenForo's PHP requirements.
 
#7
An exception occurred: Mysqli prepare error: Unknown table engine 'InnoDB' in /home/netbilgi/public_html/library/Zend/Db/Statement/Mysqli.php on line 77
  1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
  2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
  3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
  4. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 825
  5. Zend_Db_Adapter_Abstract->fetchOne() in XenForo/Error.php at line 50
  6. XenForo_Error::unexpectedException() in XenForo/Application.php at line 295
  7. XenForo_Application::handleException()
I turned on the debug mode and now I am getting this error? Do u know how can I fix that?
 

Jake Bunce

XenForo moderator
Staff member
#10
Well the error indicates it's not enabled. If you enabled it in your configuration then maybe you need to restart the server.