• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 I have been getting this error alot lately.

RAHSTYLES

Active member
#1
Server Error Log
Error Info
Zend_Http_Client_Adapter_Exception: Read timed out after 10 seconds - library/Zend/Http/Client/Adapter/Socket.php:512
Generated By: Unknown Account, Yesterday at 1:52 PM
Stack Trace
#0 /home/rahstyl1/public_html/forum/library/Zend/Http/Client/Adapter/Socket.php(330): Zend_Http_Client_Adapter_Socket->_checkSocketReadTimeout()
#1 /home/rahstyl1/public_html/forum/library/Zend/Http/Client.php(989): Zend_Http_Client_Adapter_Socket->read()
#2 /home/rahstyl1/public_html/forum/library/Zend/Service/ReCaptcha.php(487): Zend_Http_Client->request('POST')
#3 /home/rahstyl1/public_html/forum/library/Zend/Service/ReCaptcha.php(502): Zend_Service_ReCaptcha->_post('03AHJ_Vut4vv_TW...', '????????')
#4 /home/rahstyl1/public_html/forum/library/XenForo/Captcha/ReCaptcha.php(53): Zend_Service_ReCaptcha->verify('03AHJ_Vut4vv_TW...', '????????')
#5 /home/rahstyl1/public_html/forum/library/XenForo/Captcha/Abstract.php(129): XenForo_Captcha_ReCaptcha->isValid(Array)
#6 /home/rahstyl1/public_html/forum/library/XenForo/ControllerPublic/Register.php(200): XenForo_Captcha_Abstract::validateDefault(Object(XenForo_Input))
#7 /home/rahstyl1/public_html/forum/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_Register->actionRegister()
#8 /home/rahstyl1/public_html/forum/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#9 /home/rahstyl1/public_html/forum/index.php(13): XenForo_FrontController->run()
#10 {main}
Request State
array(3) {
["url"] => string(48) "http://www.rahstyles.net/forum/register/register"
["_GET"] => array(0) {
}
["_POST"] => array(17) {
["username"] => string(11) "Wetebreeria"
["email"] => string(21) "ApospixHesse@urx7.com"
["password"] => string(8) "********"
["password_confirm"] => string(8) "********"
["dob_month"] => string(2) "10"
["dob_day"] => string(2) "10"
["dob_year"] => string(4) "1983"
["gender"] => string(4) "male"
["custom_fields"] => array(3) {
["Orientation"] => string(1) "2"
["marital_status"] => string(1) "2"
["how_did_you_find_us"] => string(13) "Chicago Bulls"
}
["custom_fields_shown"] => array(3) {
[0] => string(11) "Orientation"
[1] => string(14) "marital_status"
[2] => string(19) "how_did_you_find_us"
}
["timezone"] => string(10) "Asia/Dubai"
["recaptcha_response_field"] => string(8) ""
["recaptcha_challenge_field"] => string(206) "03AHJ_Vut4vv_TW1UwiVvk9nNId42rtodEJRUvDnb_7kdfnsX07jJKDOHBxqN3aHpckP654kLgd-B6EJREpBnk5ssHv4Uf93pftE0su0gf42sQP3Ag6u8O0H5h-7JyIn-ErpVCH1JtBdJoxjZlQT4oUIDnWHahx-THt5WBFIoMOgxosoN3Tf65mf_g3I1EYqLdP4dxth3HzTSc"
["agree"] => string(1) "1"
["submit"] => string(7) "Sign up"
["_xfToken"] => string(8) "********"
["reg_key"] => string(32) "d70d42eb9362a3c059536bc30f2950d2"
 

Mike

XenForo developer
Staff member
#2
This indicates that your server had problems connecting to reCAPTCHA's. If it's happening regularly, you may wish to switch to a different CAPTCHA method.
 

RAHSTYLES

Active member
#3
This indicates that your server had problems connecting to reCAPTCHA's. If it's happening regularly, you may wish to switch to a different CAPTCHA method.
Does this happen to people alot? Or am I the only one with this kind of problem.. ? Is this a server side problem or coding in the forum?
 

Mike

XenForo developer
Staff member
#4
This is a server issue. It relates mostly to your server's connections to reCAPTCHA's, though it does also depend on the reCAPTCHA server not having problems. Regardless, the end result is that the CAPTCHA is ignored if the check request fails.
 

RAHSTYLES

Active member
#5
This is a server issue. It relates mostly to your server's connections to reCAPTCHA's, though it does also depend on the reCAPTCHA server not having problems. Regardless, the end result is that the CAPTCHA is ignored if the check request fails.
I noticed befoe that.. if i reload the captcha the third time it fails...