1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I get this error due to a addon that I can't uninstall

Discussion in 'Troubleshooting and Problems' started by Puntocom, Jan 15, 2011.

  1. Puntocom

    Puntocom Well-Known Member

    I got this error in the server log:

    call_user_func(xPortal_Install::uninstallCode) [<a href='function.call-user-func'>function.call-user-func</a>]: First argument is expected to be a valid callback


    xPortal still appears in Options but the addon is uninstalled. Any idea how can I get rid of this problem? I have re-uploaded library/ files of XF Beta 6 but it hasn't worked.

    Now when I press F5 to reload in the forum index, sometimes I get:

    The following error occurred

    The server responded with an error. The error message is in the console.

    Update: I don't know if the problem is due to the plugin.
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Make sure you uninstall the addon before removing its files.
    Puntocom likes this.
  3. Puntocom

    Puntocom Well-Known Member

    I removed the addon uninstalling from ACP (Beta 6)
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Have you contacted the author of xPortal about this? That would probably be best.
  5. Puntocom

    Puntocom Well-Known Member

    Yes, anyway, my users don't have this problem, the error log was caused only when trying to uninstall.

    I'm not sure what has caused the problem. Clicking repeatedly on Forums I get this sometimes:

  6. a legacy reborn

    a legacy reborn Well-Known Member

    You should go to your database and remove any references to xPortal. Also if anything still shows in the acp options I recommend going to debug mode and deleting those options. If I am wrong correct me because I am not 100% sure I understand what you are asking. Above error, happens on another forum I visit, but I don't think they ever used xPortal.
    Puntocom likes this.
  7. Puntocom

    Puntocom Well-Known Member

    The problem has been solved reverting some templates, it has nothing to do with the addon, thanks!

Share This Page