• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

I can't upload avatar

#1
When im trying to uplad an avatar on my forum, I've this terror:
Code:
 Server Error

mkdir() [function.mkdir]: Permission denied
XenForo_Application::handlePhpError()
mkdir() in XenForo/Helper/File.php at line 66
XenForo_Helper_File::createDirectory() in XenForo/Model/Avatar.php at line 330
XenForo_Model_Avatar->_writeAvatar() in XenForo/Model/Avatar.php at line 201
XenForo_Model_Avatar->applyAvatar() in XenForo/Model/Avatar.php at line 69
XenForo_Model_Avatar->uploadAvatar() in XenForo/ControllerAdmin/User.php at line 520
XenForo_ControllerAdmin_User->actionAvatarUpload() in XenForo/FrontController.php at line 310
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
XenForo_FrontController->run() in /var/www/domain.com/htdocs/admin.php at line 13
Please, can You help me with fixing that?
 

Brogan

XenForo moderator
Staff member
#2
Have you set the permissions for the /data and /internal_data directories, and all sub directories?

3. Setting Permissions

Once the files are finished uploading, you must set permissions (or CHMOD) several places. This is necessary to ensure that XenForo can write to those parts of your server. You can usually do this with your FTP client.
  1. In the set of files and directories you just uploaded, you will see 2 folders: data and internal_data.
  2. These two directories must be set to world writeable (CHMOD 0777) or give the IUSR_ Full Control in Windows.
http://xenforo.com/help/installation/
 

Brogan

XenForo moderator
Staff member
#7
Check the overall permissions at the server level.

Your host should be able to help you with that.
 

Brogan

XenForo moderator
Staff member
#11
I just tried using the details provided via PC and I'm getting server error.

Check your ACP server error logs and also the Apache logs.
 

Brogan

XenForo moderator
Staff member
#15
I can only respond to the information you provide, and the error log is clearly showing a permissions error.

You need to resolve that.