XF 2.2 HTTP ERROR 503 after import from vB5 and install plugin

Blockhead

Member
That sounds like a server issue. I've had a 503 error on a host once because I've had a resource usage spike. It might be that (That is if you are on a shared hosting package and not a VPS or a dedicated server). You can retry after a while (or if you have one check the control panel logs on resource usage)
 

fontana.sml

New member
That sounds like a server issue. I've had a 503 error on a host once because I've had a resource usage spike. It might be that (That is if you are on a shared hosting package and not a VPS or a dedicated server). You can retry after a while (or if you have one check the control panel logs on resource usage)
Thanks for the reply. looking for information about the error, I read that the problem could be this, but looking at the amount of resources used by the VPS, I am very far from 100%. other ideas? do you think it has nothing to do with add on and translation?
 

Blockhead

Member
I'd say you can try and make a simple PHP info file, put it in a folder or subdomain and try going there in the web browser. If it still returns a 503 then my guess is it's server related in which case either wait it out or check webserver error logs. If it works then it could be something to do with the importer however I've never ran it myself or encountered something similar when installing addons. Maybe someone who did can fill in. Checking webserver error logs in this case could be useful too
 

fontana.sml

New member
I'd say you can try and make a simple PHP info file, put it in a folder or subdomain and try going there in the web browser. If it still returns a 503 then my guess is it's server related in which case either wait it out or check webserver error logs. If it works then it could be something to do with the importer however I've never ran it myself or encountered something similar when installing addons. Maybe someone who did can fill in. Checking webserver error logs in this case could be useful too
i created a simple php file with phpinfo () ;, put it in the forum folder and it works fine

the forum, after the import, worked regularly. precisely it stopped working right after I enabled the Italian language on the forum.

but, considering the error, could it be the URL rewrite add-on?
 

Blockhead

Member
Strange. When going to your forum subdomain I don't get any errors. Simply a blank screen. You could try disableing the redirect addon via a database and seeing if that works. You can find addons in the xf_addon table in the database. There should be a row there called "Active". Set it to 0 for the redirect addon
 

fontana.sml

New member
I disabled the add on and deleted .htaccess
I turn on the board (from database)
now I see a blank page!

in the apache error log I see this:

[Tue Aug 17 12: 07: 09.530944 2021] [proxy_fcgi: error] [pid 129652: tid 140646030268160] [client 40.91.111.3:1793] AH01071: Got error 'Primary script unknown'
[Tue Aug 17 12: 07: 12.291741 2021] [proxy_fcgi: error] [pid 129652: tid 140645263988480] [client 84.223.239.83:43250] AH01071: Got error 'Primary script unknown', referer: https://www.google .com /

how can i delete the italian translation? is the last thing I have left to do ...
 

Blockhead

Member
Looking at these errors I see that some people on other forums are saying that the htaccess file might be wrong. Try pasting this default one. See if it helps

Code:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 405 default
ErrorDocument 406 default
ErrorDocument 500 default
ErrorDocument 501 default
ErrorDocument 503 default

<IfModule mod_rewrite.c>
    RewriteEngine On

    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo

    #    This line may be needed to workaround HTTP Basic auth issues when using PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>
 

Blockhead

Member
You enable languages by the "user_selectable" row in the database. After you disable Italian it should default to English for new people (If the language was the problem you'd be able to go to an anonymous windows and visit the forum to see if it's working)
 

fontana.sml

New member
Looking at these errors I see that some people on other forums are saying that the htaccess file might be wrong. Try pasting this default one. See if it helps

Code:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 405 default
ErrorDocument 406 default
ErrorDocument 500 default
ErrorDocument 501 default
ErrorDocument 503 default

<IfModule mod_rewrite.c>
    RewriteEngine On

    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo

    #    This line may be needed to workaround HTTP Basic auth issues when using PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>
Nothing... Other idea?
 

fontana.sml

New member
You enable languages by the "user_selectable" row in the database. After you disable Italian it should default to English for new people (If the language was the problem you'd be able to go to an anonymous windows and visit the forum to see if it's working)
I have visited the site anonymously with no result, so it is not a language related issue
 

Blockhead

Member
I'm out of ideas in that case. If someone else doesn't come up with a solution you could reinstall the whole thing and go from the beginning . Sorry I couldn't be of more help
 
Top