How to prevent mail from being marked as spam with Google and other mail services?


Active member
I got my mail marked as spam with Google, and I have Plesk for control panel.

So I went and checked this things:

SPF record:

I set it like this: v=spf1 +a +mx -all


I enabled it for server (globally), then for each domain I have.


Enabled it for incoming mail, but also added DNS record (for each domain): _dmarc.domain.tld. TXT v=DMARC1; p=none

I also checked for reverse DNS, it resolves to my server (by using intodns).

Of course, I setup mail account on server with forum's domain and use it as email sending account.

Is there more what I should do? I use it for registration and similar forum related mail. Please advise.
First, use to see how your current mailsystem fares.

Be aware that a (new) mailserver is always in a disadvantage and needs to run for a while to gain a good reputation.

I ran my own mailserver for years (first Kerio Mailserver, later Axigen) but eventually switched to a hosted solution. It is complicated to keep everything secure and well configurated and was just too much a hassle.
i am using ses myself. is another service that costs more than ses but has been recommended by many folks here. they have a free tier of 100 mails which is good enough to do basic tests.
An update, if it will help someone.

Now, after some time has passed, my mail goes where it should go, i.e. in inbox of gmail.

It was just too new domain and gmail placed mail from it in spam because of it. A bit strange, but, do what I did in first post, create some content and wait for some time.
I am currently using Google Workspace, thank goodness xenforo has the settings in default.
I only linked my account with forum and granted the permission.
Working like charm.
Top Bottom