• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

How do I enable Search Engine Optimisation (SEO)/friendly URLs/remove index.php

#4
After a new install, is it sufficient to tick this option for Friendly Urls? How do i know if i have them turned on? I did not change anything else like the htaccess. Kinda confused right now :confused:
 

Brogan

XenForo moderator
Staff member
#6
After a new install, is it sufficient to tick this option for Friendly Urls? How do i know if i have them turned on? I did not change anything else like the htaccess. Kinda confused right now :confused:
Just tick the checkbox, the software does the rest.

You will know it's turned on as the index.php? will no longer appear in the URL.
 

erich37

Well-known member
#7
when going into the ACP > Home > Options > Search Engine Optimisation (SEO)

it shows the following text besides the checkbox:
-----------------------
If you enable this option, the links generated by the system will not include "index.php?". However, to enable this, mod_rewrite must be available and an appropriate .htaccess file must be in place.
------------------------

Question:
- how do I check if I do have "mod-rewrite" available ?
- which .htaccess file are you talking about ? the one file which came with the XenForo-software in the .zip-File ?

Not sure what is the best setting for SEO ?
Currently both checkboxes are being checked as per default.
 

Jake Bunce

XenForo moderator
Staff member
#8
mod_rewrite is available on most Apache servers. The .htaccess file in question is in the upload folder of the xF zip file. Just enable the option in the Admin CP and upload that .htaccess file. You will know right away if it's working or not.
 

erich37

Well-known member
#10
Just tick the checkbox, the software does the rest.

You will know it's turned on as the index.php? will no longer appear in the URL.
Brogan,
is there any other way to see if this SEO is turned on ?
I have removed the "index.php" from the URL as you suggested of how to do this in this thread.

So as I have removed this "index.php" from the URL, I am not sure if I have enabled SEO properly or not ?