1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 How can I prevent this kind of server error's ? Or What is causing this?

Discussion in 'Troubleshooting and Problems' started by RoldanLT, Jan 8, 2014.

  1. RoldanLT

    RoldanLT Well-Known Member

    Server Error Log

    • Error Info
    Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Deadlock found when trying to get lock; try restarting transaction - library/Zend/Db/Statement/Mysqli.php:214
    Generated By: lord_gee, Today at 12:30 PM


    • Stack Trace
    #0 /library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
    #1 /library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
    #2 /library/Zend/Db/Adapter/Abstract.php(632): Zend_Db_Adapter_Abstract->query('UPDATE `xf_foru...', Array)
    #3 /library/XenForo/DataWriter.php(1628): Zend_Db_Adapter_Abstract->update('xf_forum', Array, 'node_id = 202')
    #4 /library/XenForo/DataWriter.php(1597): XenForo_DataWriter->_update()
    #5 /library/XenForo/DataWriter.php(1393): XenForo_DataWriter->_save()
    #6 /library/XenForo/DataWriter/Discussion.php(542): XenForo_DataWriter->save()
    #7 /library/XenForo/DataWriter/Discussion.php(431): XenForo_DataWriter_Discussion->_updateContainerPostSave()
    #8 /library/XenForo/DataWriter.php(1397): XenForo_DataWriter_Discussion->_postSave()
    #9 /library/XenForo/ControllerPublic/Forum.php(678): XenForo_DataWriter->save()
    #10 /library/Tinhte/XenTag/XenForo/ControllerPublic/Forum.php(28): XenForo_ControllerPublic_Forum->actionAddThread()
    #11 /library/XenForo/FrontController.php(347): Tinhte_XenTag_XenForo_ControllerPublic_Forum->actionAddThread()
    #12 /library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #13 /index.php(13): XenForo_FrontController->run()
    #14 {main}


    • Request State
    array(3) {
    ["url"] => string(74) "/forums/mobile-network-help-support.202/add-thread"
    ["_GET"] => array(1) {
    ["/forums/mobile-network-help-support_202/add-thread"] => string(0) ""
    }
    ["_POST"] => array(12) {
    ["prefix_id"] => string(1) "8"
    ["title"] => string(15) "opera unli surf"
    ["message"] => string(139) "pwede ba magtanong...? yung opera unli surf 85 for 7-days sa smart ba pwede sa smart bro sim...? saka my limit ba ang download nya.. thanks"
    ["_xfRelativeResolver"] => string(99) "/forums/mobile-network-help-support.202/create-thread?ModPagespeed=noscript"
    ["tinhte_xentag_tags_text"] => string(1) "1"
    ["tinhte_xentag_included"] => string(1) "1"
    ["attachment_hash"] => string(32) "b5db32a02b30f7bb98bc67d8eca83688"
    ["watch_thread"] => string(1) "1"
    ["watch_thread_email"] => string(1) "1"
    ["watch_thread_state"] => string(1) "1"
    ["poll"] => array(4) {
    ["question"] => string(0) ""
    ["responses"] => array(10) {
    [0] => string(0) ""
    [1] => string(0) ""
    [2] => string(0) ""
    [3] => string(0) ""
    [4] => string(0) ""
    [5] => string(0) ""
    [6] => string(0) ""
    [7] => string(0) ""
    [8] => string(0) ""
    [9] => string(0) ""
    }
    ["close_length"] => string(1) "7"
    ["close_units"] => string(4) "days"
    }
    ["_xfToken"] => string(8) "********"
    }
    }
     
  2. RoldanLT

    RoldanLT Well-Known Member

    I got this error maybe once a week.
    And I don't think Xentag is the reason cause sometimes I don't have that xentag included on the error.
     
  3. Brogan

    Brogan XenForo Moderator Staff Member

Share This Page