1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Help with Mysqli statement execute error

Discussion in 'Troubleshooting and Problems' started by Biirds, Oct 19, 2013.

  1. Biirds

    Biirds Member


    I was going to disable the addon XI Blog but it says that I haven't the correct files. Could I manually delete everything that has to do with this addon trough phpmyadmin?

    Right now when users try to register I get this message in the Server Error Log:
    Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Field 'blog_author_bio' doesn't have a default value - library/Zend/Db/Statement/Mysqli.php:214

    #0 /home/biirds/public_html/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
    #1 /home/biirds/public_html/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
    #2 /home/biirds/public_html/library/Zend/Db/Adapter/Abstract.php(574): Zend_Db_Adapter_Abstract->query('INSERT INTO `xf...', Array)
    #3 /home/biirds/public_html/library/XenForo/DataWriter.php(1612): Zend_Db_Adapter_Abstract->insert('xf_user_profile', Array)
    #4 /home/biirds/public_html/library/XenForo/DataWriter.php(1601): XenForo_DataWriter->_insert()
    #5 /home/biirds/public_html/library/XenForo/DataWriter.php(1393): XenForo_DataWriter->_save()
    #6 /home/biirds/public_html/library/XenForo/ControllerPublic/Register.php(679): XenForo_DataWriter->save()
    #7 /home/biirds/public_html/library/XenForo/FrontController.php(337): XenForo_ControllerPublic_Register->actionFacebookRegister()
    #8 /home/biirds/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #9 /home/biirds/public_html/index.php(13): XenForo_FrontController->run()
    #10 {main}

    Would be nice to get help with this because no user can register for my site at the moment..
  2. Brogan

    Brogan XenForo Moderator Staff Member

    You will need to contact the author of the add-on to find out which database tables were altered.
    Uninstalling the add-on should automatically revert any changes.
    You will need the files in place to do that though.
  3. Biirds

    Biirds Member


    Ok, thanks. I have tried uninstalling it but it says I don't have the necessary files to do so. I have then tried to remove some stuff from phpmyadmin. I've contacted the developer and asked for help with this.

Share This Page