1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help upgraded to 1.1.2 killed my start/homepage but not other pages

Discussion in 'Installation, Upgrade, and Import Support' started by justwordme, Feb 8, 2012.

  1. justwordme

    justwordme Active Member

    I just upgraded to 1.1.2. and I can no longer access my home page. Although I can access other pages with direct linking to the correct subdomain addresses. I've disabled every add-on (originally thinking it was a Xenporta issue) as well as changing changed my Style back to default. I've also re-uploaded every file and re-installed/rebuilt I also ran the File Health check. This is my third or fourth upgrade so I figure by now I cannot screw it up but something went wrong....fortunately (actually unfortunately) I haven't got hardly any users yet.

    Ideas??? Help please........
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    You will have to provide some more details - it's impossible to diagnose a problem with virtually no information.

    What does your start/home page composed of?
    Is it a custom HTML page, part of an add-on?
    What error do you get?
    Anything in the ACP error log?
    Do you have outdated templates? Have you reverted them and reapplied your customisations?
    What is the link to your start/home page and forum?
     
  3. justwordme

    justwordme Active Member

    Home/start page is/has been Xenporta However I turned off/disabled
    I have no custom HTML
    No error just a blank page (using chrome)
    Oh wow there is an error there here is error: Library/zend/Db/statement/Mysquli.php:77
    I do have some outdated templates not sure if there from a previous upgrade or new (I not know how to fixing this)
    Link and error code sent as a PM

    Thanks for any and all help
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    As you have disabled the portal add-on then that explains why your home page is no longer working.
    You will need to reverse any changes made as part of the portal add-on - I don't use it so you will need to ask in the add-on thread.

    You will need to revert any outdated templates and reapply any customisations - it's impossible to know what state your templates are in otherwise.

    Run a file health check in the ACP and confirm all files are as expected. Reupload any which fail the check.
     
  5. justwordme

    justwordme Active Member

    File Check has been run everything ok

    I'm using a Style that has no template issues

    I have enabled and disabled the Xenporta portal add-on no difference made...I've even enabled and unchecked all boxes for directory control etc

    My thinking is with all add-ons disabled and using styles that have no template issues then things should work?...but don't
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Well upgrading to 1.1.2 won't have affected your home page, so it is something else you have done.

    Right now your domain root URL is just a blank page - there is nothing there.
    If you want that to automatically redirect to your forum home page then you will need to do a redirect to /forum.
     
  7. justwordme

    justwordme Active Member

    Uhm.....It worked before the upgrade....I think the domain root URL was changed as a setting of Xenporta long ago and worked just fine before upgrade. Unfortunately I have no idea how to fix that as I've not modified or know where to learn how to modify that.
     
  8. Cool

    Cool Active Member

    just upgraded and all went just fine. site is working normal also xenporta.
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    You will have to ask in the add-on thread.

    I don't use that add-on so have no idea what changes are required.
     
  10. madaroda

    madaroda Member

    I'm having what seems like the same problem, though I am not running xenporta. The main forum site (http://forum.voxilla.com or http://voxilla.com/forum) brings up a blank page. I can access the control panel, and it shows that 1.1.2 is installed. File health check returns: "All 1,065 checked files are present and correct." Forum ran correctly before the upgrade. Clues?
     
  11. justwordme

    justwordme Active Member

    Oh thank goodness I'm not alone. Mine is still broken Xenporta disabled or not. I cannot see it being a Xenporta issue.
     
  12. madaroda

    madaroda Member

    I tracked my issue down. A blank index.html file got added to the forum's root folder at some point during the upgrade process. I do not know how this happened, but deleting this file fixed the problem. I hope this helps you justwordme.
     
  13. justwordme

    justwordme Active Member

    Oh cool thanks. I just looked at the upgrade files it appears there are at least two blank index.html files that it has us upload. Why it has us uploading empty blank files I not know enough to know why? How do I fix this do I just delete or add some text?
     
  14. steel_curtain

    steel_curtain Well-Known Member

    Leave the index.html files in all directories except the root if you have one there. You should have an index.php in your forum root. The others are provided as security. That way if someone navigates to one of your other directories they see a blank page instead of the index of files and folders.
     
  15. justwordme

    justwordme Active Member

    Hallelujah....Thank you all. Fixed by deleting the blank index.html I don't know where file came from as it doesn't appear to be part of the upload.
     

Share This Page