• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Help! Forum is totally inaccessible

#1
Hi,

Could anyone help? My forum has went down. I can't access control panel, upgrade it to 1.5 or anything.

This is the error message below.


image.png



This is typical. We have a Christmas fund raiser we are organising for this weekend and we can't access the forum.

Help will be greatfully appreciated


Thanks

Stephen
 

Chris D

XenForo developer
Staff member
#2
Are you hosted with 1and1?

Looks like a fellow customer had the same issue today:

@Mike got it sorted, looks like a problem with 1and1. They have added a new option in the hosting control under Manage Webspace panel called PHP settings, you have to go in there and set the PHP version as all domains are set to "no version set", i set it to Version 5.6 and boom all started working as normal.

thanks for you help tho and hopefully this may help any other people that may come across this problem with 1and1 hosting and Xenforo.
 

Chris D

XenForo developer
Staff member
#6
This does seem to be a change they made, but I can't see why the effect of it would be intentional. We suspect it may well be defaulting to using a much older version of PHP. Although your issue is now solved, it may well be worth reporting it to 1and1 so they can investigate and fix the issue for other customers.