• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Won't fix Google Rich Snippets Testing Tool & XenForo Relative URLs

James

Well-known member
#1
I'm not even sure this is a bug, but here we go:

I was having a fiddle with Google's Rich Snippets Testing Tool and it seems that due to the relative URLs in the avatar block, it is resulting in invalid URLs for member info.

Take this thread for example, when I use the tool to extract the data, the avatar information shows up relative:

The bold areas in the URLs are set relative to the thread URL.

To see for yourself: http://www.google.com/webmasters/tools/richsnippets?url=http://xenforo.com/community/threads/xenforo-1-0-0-release-candidate-2.11501/
 

Kier

XenForo Developer
Staff member
#3
I'm not entirely sure that we would want to 'fix' this - forcing all URLs to be absolute and fully qualified seems a bit ridiculous really.
 

Kier

XenForo Developer
Staff member
#4
I think on balance the onus should be on Google to recognise the <base href /> tag, as it's not just this that will be affected, but essentially every URL on any site with rewritten URLs.
 

tenants

Well-known member
#5
I've just run into a similar issue for relative urls and Google

It's detecting the relative nav bar links incorrectly on certain pages

so it picks up things like:
example.com/something/somthingelse/help/bb-codes
as a 404, but humans correctly click the link and visit example.com/help/bb-codes

and the base href was in place for those locations