• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Google indexing problems

#1
hi everyone


hi everyone
i'm having a big problem with my forum . i always submit keyword rich content and have been doing very well in google for the past 2 years we had more then 700,000+ pages indexed by google & we used to have a really high ranking. after i've converted my forum from vb to xenforo since 6 months ago For some reason we lost our ranking in google and all of our external site links. & now we only have 48,000 pages indexed by google & the number is still decreasing .

well after i converted from vb to xenforo i've used a 301 redirect to redirect my old links to the new ones

the old link : http://www.afaqmaroc.com/vb/
the new link : http://www.afaqmaroc.com/forum/

by the way my forum is an arabic forum
I am looking for support as to why this has happened. We have followed all the rules for google.
 

Jake Bunce

XenForo moderator
Staff member
#4
yes i redirected threads & the old link isn't available anymore in google
Since the old links are no longer in Google there isn't much more to do. XenForo already has good SEO built-in. It is now a matter of getting your link out there on other sites to bring in traffic and increase your page rank.
 
#5
i have the same problem.

Since i moved from vb to xenforo, google is not indexing my threads anymore (or very slow, just few pages a week). I lost also my ranking on google.

The old vb urls are removed from google.

Any advice?
 
#6
We have moved from VB to Xenforo end of January this year.
Now almost 3 month later, google still needs really long to index our new threads/posts.

Our new posts were indexed before in google within 2 or 3 hours
Now it takes days!
I really can't figure why :(
 

Jake Bunce

XenForo moderator
Staff member
#7
We have moved from VB to Xenforo end of January this year.
Now almost 3 month later, google still needs really long to index our new threads/posts.

Our new posts were indexed before in google within 2 or 3 hours
Now it takes days!
I really can't figure why :(
Make sure the content is accessible to guests (not logged in).

You can also submit your URL here:

http://www.google.com/addurl.html