1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Google indexing problem

Discussion in 'Server Configuration and Hosting' started by samresp, May 5, 2012.

  1. samresp

    samresp New Member

    I've got wordpress installed on my root folder. XF is at /forum . I noticed that my Google can't index my new XF posts correctly, as it takes more than a week to get indexed.

    I use Sitemaps for Xenforo addon. Sitemaps are added to WebmasterTools and it works very well. It detects the other sitemaps fine. However it looks like I'm missing something here.

    How do you guys recommend me to setup sitemaps for a correct google indexing?

    thanks
     
  2. mrGTB

    mrGTB Well-Known Member

    Do you have the htaccess file that comes with forum located inside the "forum folder" used. So you have two htaccess files, one in ROOT used by WordPress, the other used by XenForo located in your forum folder.

    If Yes and that's were it should be, you may be required (but not always, try untouched at first) and see if friendly URL's work when activated in settings? If not, change this line in it from this below:

    To this instead:

    Out of interest; I'm not sure why XenForo by default doesn't have a last trailing backslash after this line "#RewriteBase /xenforo" to look like this instead #RewriteBase /xenforo/". Maybe Kier can explain that one, as I would have though it's the correct way from my past experience and how I see it advertised as done on AskApache. But if not due to how XenForo works differently he can explain.

    Also not sure why default htaccess file doesn't include this line as well: "Options +FollowSymLinks"?

    Try this also last if still not working on Friendly URL's (but think that's not right unless Kier explains otherwise):

     
  3. samresp

    samresp New Member

    thanks mrGTB for your help.
    As you say , there are 2 different htaccess files; one for Wordpress in the root and one at my xenforo folder.
    I've just removed the '#' from the line at my xenforo folder .htaccess file.
    I must say that friendly URL's work smoothly before doing that. So I hope this helps indexing as it should.
    I'll keep you updated,
    thanks again
     
  4. samresp

    samresp New Member

    A few days after mrGTB's tip my XF won't get cached by google. Any suggestions is much appreciated.

    This is my root's folder .htaccess (Wordpress generated plus 3 lines of slash domain redirection)

    HTML:
    # BEGIN WordPress
     
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
     
    # END WordPress
    RewriteCond %{HTTP_HOST} ^respuesta-facil.com$ [OR]
    RewriteCond %{HTTP_HOST} ^www.respuesta-facil.com$
    RewriteRule ^/?$ "http\:\/\/www\.respuestafacil\.com" [R=301,L]
    And this is the xenforo's folders .htaccess

    HTML:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    #</IfModule>
     
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
     
    <IfModule mod_rewrite.c>
        RewriteEngine On
     
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        RewriteBase /foro/
     
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
     
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
     

Share This Page