• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Other GIF images

Brad P

Active member
#1
Hello. This is a paid request.

I need someone that will be able to enable GIF images on my site. They was working before I had to restore the site. It's stopped working. Still shows some members avatars working as GIF images but when you upload a GIF it does not work.
 

Brad P

Active member
#12
The above I said is installed. So there must be an issue somewhere. Hence why I am asking for support as a paid job.

I do appreciate your time with what you have asked
 

rafass

Well-known member
#14
This is what I did on my server and all the gifs are working perfect:
  1. Remove existing ImageMagick packages.
    yum remove ImageMagick
  2. Remove existing PECL imagick package.
    pecl uninstall imagick
  3. Download latest ImageMagick source. Latest is ImageMagick 6.8.6-9 at the time of posting.
    wget http://www.imagemagick.org/download/ImageMagick.tar.gz
  4. Extract tarball.
    tar zxvf ImageMagick.tar.gz
  5. Compile and install.
    cd ImageMagick-6.8.6-9
    ./configure --prefix=/usr && make && make install
  6. Configure the dynamic linker run-time bindings
    ldconfig /usr/bin
  7. Install latest version of PECL imagick package. Latest is imagick 3.1.0 (RC3) at the time of posting.
    pear config-set preferred_state beta
    pecl install imagick
    pear config-set preferred_state stable
Source: Animated avatars with Imagick not working